Bug 134588 - [GTK] The list of features shown by cmake is not accurate
Summary: [GTK] The list of features shown by cmake is not accurate
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk
Depends on:
Blocks: 134589
  Show dependency treegraph
 
Reported: 2014-07-03 02:12 PDT by Carlos Garcia Campos
Modified: 2014-07-03 06:37 PDT (History)
8 users (show)

See Also:


Attachments
Patch (2.00 KB, patch)
2014-07-03 02:15 PDT, Carlos Garcia Campos
no flags Details | Formatted Diff | Diff
Different approach (5.50 KB, patch)
2014-07-03 03:02 PDT, Carlos Garcia Campos
gns: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2014-07-03 02:12:26 PDT
The problem is that some options might change after the feature list has been printed. Optional features might be disabled because their deps were not found, for example.
Comment 1 Carlos Garcia Campos 2014-07-03 02:15:53 PDT
Created attachment 234327 [details]
Patch
Comment 2 Carlos Garcia Campos 2014-07-03 02:38:23 PDT
Comment on attachment 234327 [details]
Patch

This doesn't really work, because it's WEBKIT_OPTION_DEFAULT_PORT_VALUE then once actually setting ENABLE_FOO
Comment 3 Carlos Garcia Campos 2014-07-03 03:02:55 PDT
Created attachment 234329 [details]
Different approach

Ok, I think this should work fine.
Comment 4 Gustavo Noronha (kov) 2014-07-03 05:53:24 PDT
Comment on attachment 234329 [details]
Different approach

Makes sense!
Comment 5 Carlos Garcia Campos 2014-07-03 06:37:17 PDT
Committed r170751: <http://trac.webkit.org/changeset/170751>