Bug 134554 - fix webgl crash
Summary: fix webgl crash
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebGL (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Alex Christensen
URL: https://www.khronos.org/registry/webg...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-02 13:22 PDT by Alex Christensen
Modified: 2014-07-02 14:34 PDT (History)
11 users (show)

See Also:


Attachments
Patch (1.75 KB, patch)
2014-07-02 13:24 PDT, Alex Christensen
dino: review+
buildbot: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-16 for mac-mountainlion-wk2 (535.23 KB, application/zip)
2014-07-02 14:33 PDT, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Christensen 2014-07-02 13:22:16 PDT
A khronos test crashes without this change.
<rdar://problem/17540462>
Comment 1 Alex Christensen 2014-07-02 13:24:35 PDT
Created attachment 234274 [details]
Patch
Comment 2 Dean Jackson 2014-07-02 13:27:08 PDT
Comment on attachment 234274 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=234274&action=review

> Source/WebCore/ChangeLog:7
> +
> +        Reviewed by NOBODY (OOPS!).

Mention the khronos test that exercises this.
Comment 3 Build Bot 2014-07-02 14:33:32 PDT
Comment on attachment 234274 [details]
Patch

Attachment 234274 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/5273111880531968

New failing tests:
media/media-fragments/TC0001.html
Comment 4 Build Bot 2014-07-02 14:33:36 PDT
Created attachment 234279 [details]
Archive of layout-test-results from webkit-ews-16 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-16  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 5 Alex Christensen 2014-07-02 14:34:50 PDT
This was committed to http://trac.webkit.org/changeset/170718
I'm pretty sure this did not cause that failure.