Bug 13380 - REGRESSION (419-522+) The "Edit in TextMate" InputManager beeps once instead of working.
Summary: REGRESSION (419-522+) The "Edit in TextMate" InputManager beeps once instead ...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh Intel OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.google.com
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-17 23:35 PDT by Michael Friedman
Modified: 2007-04-18 05:26 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Friedman 2007-04-17 23:35:15 PDT
TextMate (http://www.macromates.com/) comes with an "Edit in TextMate" InputManager which you can use in Safari (or any other Cocoa app) to edit the contents of the current Cocoa text editor control in a new window in TextMate itself. After editing, you save the temporary file and the InputManager puts the new text into the original text editor control.

In Mac OS X 10.4.9's WebKit (build 419) this works great. In the nightly builds as of at least 16 April 2007, it does not. Instead of doing anything, it beeps once. No messages go to the console or the Terminal window where I started run-safari.

To reproduce this:
1. Install TextMate.
2. Install "Edit in TextMate" from TextMate (Bundles->TextMate->Install "Edit in TextMate"...).
3. run-safari &
4. Go to any page with a form, such as http://www.google.com/ , click in the field to put the cursor there, and then chose Edit->Edit in TextMate from the menu.

5. In Safari with 419 WebKit, this opens a new document in TextMate containing what was in that field. In WebKit 522+, it just beeps.
Comment 1 Mark Rowe (bdash) 2007-04-18 05:26:08 PDT
"Edit in TextMate" is an InputManager extension to Safari which is completely unsupported.  It hooks into WebKit internals which have changed since Safari 2.0, and likely needs to be updated to accommodate the new internal structure.  This is in no way a WebKit issue.