Bug 13340 - Attempting to play second movie crashes on Leopard
Summary: Attempting to play second movie crashes on Leopard
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.5
: P2 Blocker
Assignee: Nobody
URL: http://www.apple.com/getamac/
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-04-12 06:51 PDT by Marc Epard
Modified: 2007-04-27 13:32 PDT (History)
1 user (show)

See Also:


Attachments
Crash log (27.45 KB, text/plain)
2007-04-12 06:53 PDT, Marc Epard
no flags Details
Another crash log (32.22 KB, text/plain)
2007-04-12 06:53 PDT, Marc Epard
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Epard 2007-04-12 06:51:29 PDT
Play one movie (e.g. Flashback) to the end, then click another movie (e.g. Computer Cart) and boom.  I've done it twice, playing the movies in different orders.
Comment 1 Marc Epard 2007-04-12 06:53:11 PDT
Created attachment 14018 [details]
Crash log
Comment 2 Marc Epard 2007-04-12 06:53:45 PDT
Created attachment 14019 [details]
Another crash log
Comment 3 Matt Lilek 2007-04-12 15:41:55 PDT
I can't reproduce this on Tiger (10.4.9 8P135)
Comment 4 mitz 2007-04-13 00:14:29 PDT
(In reply to comment #3)
> I can't reproduce this on Tiger (10.4.9 8P135)
> 

Me neither, but I could reproduce it on the configuration that appears in the crash logs. The bug might be in the QuickTime WebKit plugin (or in WebKit). Radar might be a better place for it.
Comment 5 Marc Epard 2007-04-13 04:40:52 PDT
FWIW, it still happens with 20865. If it's a bug in Leopard, WebKit has done something lately to expose it.  I've been using nightly WebKit builds against this Leopard seed for some time and haven't had these crashes.   I'll try it with the latest Leopard seed later today.  Also, I've had fairly frequent crashes and some seem unrelated to playing movies, but I'm not sure I didn't play a movie sometime earlier each time.  If the crashes still happen on the new Leopard build, I'll gather more information.
Comment 6 David Kilzer (:ddkilzer) 2007-04-13 11:48:32 PDT
This bug needs a Radar, although it's not clear whether it's a WebKit bug or not.  Marc, if you have an ADC account, please file a bug using https://bugreport.apple.com/.  If you don't have an account, you may create a free "online" ADC account using https://connect.apple.com/.  Please note the Bugzilla bug URL in the Radar, and note the Radar bug number (not the URL, which is session-specific) here.

Thanks!

Comment 7 Marc Epard 2007-04-15 07:28:06 PDT
I do have an ADC account, but I just tried to reproduce this with the latest nightly along with the latest Leopard seed and no crash occurred.  If it does show up again, I'll file a bug in Radar.
Comment 8 Mark Rowe (bdash) 2007-04-27 02:58:54 PDT
<rdar://problem/5166141>
Comment 9 Stephanie Lewis 2007-04-27 13:32:49 PDT
This is fixed on the latest seed.