Bug 13338 - loading any page of this site crashes nightly build (also crashes safari)
Summary: loading any page of this site crashes nightly build (also crashes safari)
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://dailymercury.com.au/
Keywords:
Depends on:
Blocks:
 
Reported: 2007-04-12 02:27 PDT by Jaap Kreijkamp
Modified: 2007-04-20 12:29 PDT (History)
0 users

See Also:


Attachments
crash report on iBook (G4) for dailymercury.com.au (24.20 KB, text/plain)
2007-04-13 01:35 PDT, Jaap Kreijkamp
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaap Kreijkamp 2007-04-12 02:27:58 PDT
loading pages from the http://dailymercury.com.au/ website almost guarantees a crash of safari and webkit. As this is the newspaper of the mackay region i'm gonna move  to, it's at least critical to me ;-)
Comment 1 Jaap Kreijkamp 2007-04-12 02:40:07 PDT
crashes both on PPC and Intel
Comment 2 David Kilzer (:ddkilzer) 2007-04-12 06:27:28 PDT
Hi Jaap, thanks for the bug report!  Could you post a stack trace of the crash?

When I load the page, I get some console "spew" using a local debug build of WebKit r20858 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).  The numbers apparently don't ever stop:

ERROR: could not show status message (Applet hostapplet stopped) because plug-in has already been destroyed
(/path/to/WebKit/WebKit/Plugins/WebPluginController.mm:341 -[WebPluginController webPlugInContainerShowStatus:])
ERROR: could not show status message (Applet hostapplet notstarted) because plug-in has already been destroyed
(/path/to/WebKit/WebKit/Plugins/WebPluginController.mm:341 -[WebPluginController webPlugInContainerShowStatus:])
ERROR: could not show status message (Applet hostapplet destroyed) because plug-in has already been destroyed
(/path/to/WebKit/WebKit/Plugins/WebPluginController.mm:341 -[WebPluginController webPlugInContainerShowStatus:])
ERROR: could not show status message (Applet hostapplet disposed) because plug-in has already been destroyed
(/path/to/WebKit/WebKit/Plugins/WebPluginController.mm:341 -[WebPluginController webPlugInContainerShowStatus:])
**http://www.bourseinvestor.com/java_applets/stock_ticker/standard/data/quote_list.asp?asxcodes=APN,BHP,CBA,ANZ,WBC,RIO,NAB,SGB,TLS,RIN,NCM,QBE,FGL,WDC,WOW,AGL,CSL,MBL,NWS,MAP,QAN
76
74
72
70
68
66
64
62
[...]

Comment 3 Jaap Kreijkamp 2007-04-13 01:35:52 PDT
Created attachment 14024 [details]
crash report on iBook (G4) for dailymercury.com.au

Seems the crash doesn't occur every try at the moment I fail to reproduce it again on intel-arch.
Comment 4 David Kilzer (:ddkilzer) 2007-04-13 06:52:03 PDT
It looks like you have SIMBL and some InputManagers installed (Smart Crash Reports, PathwayPlugin).  Try disabling those, then see if you still see the crashing.

Comment 5 Jaap Kreijkamp 2007-04-20 00:49:04 PDT
Failed to reproduce crash after clean OS X install maybe plugin (Growl) issue?

Comment 6 David Kilzer (:ddkilzer) 2007-04-20 12:29:14 PDT
Closing per Comment #5.  Please re-open the bug if this happens again (without Growl or any Input Managers/APEs installed).  Thanks!