Bug 132937 - [iOS][WK2] Add a heuristic to set the rigth horizontal offset on rotation for broken responsive websites
Summary: [iOS][WK2] Add a heuristic to set the rigth horizontal offset on rotation for...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Benjamin Poulain
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-05-14 20:39 PDT by Benjamin Poulain
Modified: 2014-05-16 14:58 PDT (History)
0 users

See Also:


Attachments
Patch (2.69 KB, patch)
2014-05-14 20:42 PDT, Benjamin Poulain
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Benjamin Poulain 2014-05-14 20:39:42 PDT
[iOS][WK2] Add a heuristic to set the rigth horizontal offset on rotation for broken responsive websites
Comment 1 Benjamin Poulain 2014-05-14 20:42:36 PDT
Created attachment 231484 [details]
Patch
Comment 2 Benjamin Poulain 2014-05-14 20:43:34 PDT
<rdar://problem/16710097>
Comment 3 Simon Fraser (smfr) 2014-05-15 15:59:13 PDT
Comment on attachment 231484 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231484&action=review

> Source/WebKit2/ChangeLog:9
> +        When responsive websites are broken, we should not keep the relative horizontal position into view,

It's not clear what "When responsive websites are broken" means. Broken by us, or broken by design?

"keep the position into view" doesn't make sense.
Comment 4 Simon Fraser (smfr) 2014-05-15 16:00:48 PDT
Comment on attachment 231484 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=231484&action=review

> Source/WebKit2/ChangeLog:3
> +        [iOS][WK2] Add a heuristic to set the rigth horizontal offset on rotation for broken responsive websites

"rigth"
Comment 5 Simon Fraser (smfr) 2014-05-15 16:05:19 PDT
Comment on attachment 231484 [details]
Patch

Let's remove the "broken responsive" terminology.
Comment 6 Benjamin Poulain 2014-05-16 14:58:26 PDT
Committed r168982: <http://trac.webkit.org/changeset/168982>