Bug 13238 - REGRESSION: Image does not appear on item page at sears.com
Summary: REGRESSION: Image does not appear on item page at sears.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.sears.com/sr/javasr/produc...
Keywords: NeedsReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-03-30 16:24 PDT by Beth Dakin
Modified: 2009-11-27 12:01 PST (History)
3 users (show)

See Also:


Attachments
Misrendering on reload (not missing picture) (344.92 KB, image/png)
2007-03-30 19:29 PDT, David Kilzer (:ddkilzer)
no flags Details
Misrendering on reload (printed to PDF) (50.56 KB, application/pdf)
2007-03-30 19:31 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2007-03-30 16:24:34 PDT
Go to: http://www.sears.com/sr/javasr/product.do?cat=Grills&pid=07113400000&vertical=LAWN&subcat=Charcoal+Grills&BV_SessionID=@@@@0890904211.1175295668@@@@&BV_EngineID=ccccaddkhmimlgjcefecemldffidfjm.0

On the left side, there should be a large picture of the item, but on TOT, it is just blank. Works in Safari 2.0 and Firefox.
Comment 1 David Kilzer (:ddkilzer) 2007-03-30 17:11:06 PDT
Works for me with a local debug build of WebKit r20612 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).

Regressions are P1.

Comment 2 Dave Hyatt 2007-03-30 17:50:20 PDT
Repros for me.
Comment 3 David Kilzer (:ddkilzer) 2007-03-30 18:45:16 PDT
(In reply to comment #2)
> Repros for me.

I still can't reproduce this with a local debug build of WebKit r20625 with Safari 2.0.4 (419.3) on Mac OS X 10.4.9 (8P135).  I still see the big picture of the Weber grill!

Emptying the cache and then viewing the page, I am still able to see the grill (unable to reproduce).  This is on a quad-G5 box.

Comment 4 Dave Hyatt 2007-03-30 18:47:59 PDT
Most of the time I don't see the picture (like 9 reloads out of 10).  Occasionally I do.
Comment 5 David Kilzer (:ddkilzer) 2007-03-30 19:29:17 PDT
Created attachment 13898 [details]
Misrendering on reload (not missing picture)

This is a screenshot of a bad misrendering that happened one time when I loaded the page.
Comment 6 David Kilzer (:ddkilzer) 2007-03-30 19:31:04 PDT
Created attachment 13899 [details]
Misrendering on reload (printed to PDF)

This is the PDF output from when the page was loaded misrendered.  (If the page renders correctly, the PDF output looks MUCH different.)
Comment 7 David Kilzer (:ddkilzer) 2007-03-30 19:33:00 PDT
(In reply to comment #4)
> Most of the time I don't see the picture (like 9 reloads out of 10). 
> Occasionally I do.

I finally got one reload that didn't show the picture.  The misrendering attachments hung (just like they do when the photo doesn't appear), but the photo of the grill must have appeared just before Safari gave up, which caused the misrendering.

Comment 8 David Kilzer (:ddkilzer) 2007-03-30 19:37:01 PDT
(In reply to comment #7)
> (In reply to comment #4)
> > Most of the time I don't see the picture (like 9 reloads out of 10). 
> > Occasionally I do.
> 
> I finally got one reload that didn't show the picture.  The misrendering
> attachments hung (just like they do when the photo doesn't appear), but the
> photo of the grill must have appeared just before Safari gave up, which caused
> the misrendering.

Actually, this probably happened because two resources (one CSS and one JS) were not loaded:

http://content.sears.com/css/products.css
http://content.sears.com/s7/config.js (2)
Comment 9 David Kilzer (:ddkilzer) 2007-03-31 18:13:08 PDT
(In reply to comment #4)
> Most of the time I don't see the picture (like 9 reloads out of 10). 
> Occasionally I do.

Are we sure this is a browser bug?  Given the issues I've had reloading the page (where CSS and JavaScript resources simply don't load), I'm wondering if this is a server-side issue.

Comment 10 Beth Dakin 2007-04-02 11:12:55 PDT
Dave (Kilzer...ahh! too many Daves!), you might be right. This is reproducing less consistently for me on TOT today, but I still see the bug, and I noticed that it repros more readily if I switched over to another tab while the page finishes loading. In fact, I have (only occasionally) been able to repro the bug in Safari 2.0 and in Firefox by switching to another tab while sears.com is still loading. I am not sure why I can see this so much more consistently on TOT, though. Maybe because it is a timing issue and everything is a bit slower? I don't know; that doesn't quite make sense to me.

Looks like this may or may not be a bug at all. For now, I will just remove the "Regression" keyword and lower the priority.
Comment 11 Beth Dakin 2007-04-02 11:14:24 PDT
Just for clarification, when I said "everything is a bit slower" above, I meant, "everything is a bit slower because of the Debug build."
Comment 12 David Kilzer (:ddkilzer) 2007-12-08 06:22:29 PST
I can't reproduce the issue now, although the page currently references a URL that is apparently not reachable on the Internet (and is on a testing server whose URL did not get replaced):

http://sears-stage.intra.sears.com/ue/home/sears_a1_box2_120707CR.gif

Comment 13 David Kilzer (:ddkilzer) 2009-07-22 11:58:21 PDT
Clicking on the URL in Comment #0 (which amazingly still works!), I don't see the bug anymore.  Beth, do you still see the issue?
Comment 14 Adele Peterson 2009-11-27 12:01:03 PST
I can't repro this anymore either.  Closing