Bug 13214 - Right hand float is placed at the bottom of document
Summary: Right hand float is placed at the bottom of document
Status: CLOSED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://stuff.co.nz/4008837a10133.html
Keywords: HasReduction
Depends on:
Blocks:
 
Reported: 2007-03-28 04:19 PDT by Oliver Hunt
Modified: 2007-03-31 14:12 PDT (History)
1 user (show)

See Also:


Attachments
Webarchive of referenced page (296.02 KB, application/octet-stream)
2007-03-28 04:20 PDT, Oliver Hunt
no flags Details
Reduction (348 bytes, text/html)
2007-03-28 05:55 PDT, mitz
no flags Details
Apparent root cause (419 bytes, text/html)
2007-03-28 13:54 PDT, mitz
no flags Details
Regression test (48.60 KB, patch)
2007-03-28 14:54 PDT, mitz
darin: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Hunt 2007-03-28 04:19:58 PDT
The right hand column of the referenced url is placed at the bototm of the article, rather than beside it.

Firefox renders correctly
Comment 1 Oliver Hunt 2007-03-28 04:20:44 PDT
Created attachment 13841 [details]
Webarchive of referenced page
Comment 2 mitz 2007-03-28 05:55:55 PDT
Created attachment 13842 [details]
Reduction
Comment 3 Oliver Hunt 2007-03-28 13:08:06 PDT
Hmmm, the reduction doesn't seem to trigger the layout bustage i see in the webarchive :-/
Comment 4 mitz 2007-03-28 13:41:26 PDT
(In reply to comment #3)
> Hmmm, the reduction doesn't seem to trigger the layout bustage i see in the
> webarchive :-/
> 

Not seeing red?
Comment 5 Oliver Hunt 2007-03-28 13:54:33 PDT
Oh, oops

Firefox != Safari :D

Must ensure that i'm using the right browser when checking tests :D
Comment 6 mitz 2007-03-28 13:54:54 PDT
Created attachment 13848 [details]
Apparent root cause
Comment 7 mitz 2007-03-28 14:24:18 PDT
Hyatt (and I!) think that WebKit's behavior is correct, according to <http://www.w3.org/TR/2006/WD-CSS21-20061106/visudet.html#q8>. Firefox 3 also matches WebKit. So this bug is INVALID. Leaving it open until a layout test documenting this behavior is landed.
Comment 8 mitz 2007-03-28 14:54:10 PDT
Created attachment 13850 [details]
Regression test

Just add a layout test documenting the current correct behavior.
Comment 9 Darin Adler 2007-03-28 14:57:10 PDT
Comment on attachment 13850 [details]
Regression test

r=me
Comment 10 Alexey Proskuryakov 2007-03-31 03:36:39 PDT
Committed revision 20638, closing as INVALID.