Bug 131808 - [New Multicolumn] fast/multicol/multicol-with-child-renderLayer-for-input.html puts the textfield in the wrong place
Summary: [New Multicolumn] fast/multicol/multicol-with-child-renderLayer-for-input.htm...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Dave Hyatt
URL:
Keywords: InRadar
: 131984 (view as bug list)
Depends on:
Blocks: 131825
  Show dependency treegraph
 
Reported: 2014-04-17 13:37 PDT by Dave Hyatt
Modified: 2014-04-24 09:33 PDT (History)
9 users (show)

See Also:


Attachments
Test case (815 bytes, text/html)
2014-04-22 07:26 PDT, Morten Stenshorne
no flags Details
Patch (5.61 KB, patch)
2014-04-22 07:28 PDT, Morten Stenshorne
hyatt: review-
Details | Formatted Diff | Diff
Patch (4.96 KB, patch)
2014-04-22 09:02 PDT, Dave Hyatt
beidson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Hyatt 2014-04-17 13:37:34 PDT
The layer is in the wrong place. Forcing a new layout snaps it to the right place, so it's some problem where the layer position is initially incorrect (or only the widget position is incorrect and it syncs to the layer later).
Comment 1 Radar WebKit Bug Importer 2014-04-17 23:12:43 PDT
<rdar://problem/16656286>
Comment 2 Dave Hyatt 2014-04-21 13:44:03 PDT
This is a blocker for turning the new columns on.
Comment 3 Morten Stenshorne 2014-04-22 07:25:48 PDT
*** Bug 131984 has been marked as a duplicate of this bug. ***
Comment 4 Morten Stenshorne 2014-04-22 07:26:43 PDT
Created attachment 229879 [details]
Test case
Comment 5 Morten Stenshorne 2014-04-22 07:28:39 PDT
Created attachment 229880 [details]
Patch
Comment 6 Dave Hyatt 2014-04-22 08:52:46 PDT
Comment on attachment 229880 [details]
Patch

Your fix is basically just working around the fact that the flags were wrong. This is because some code is missing from FrameView. It's patched for the old columns but not for the new ones. I'll post a revised patch with your test case in a bit.
Comment 7 Dave Hyatt 2014-04-22 09:02:01 PDT
Created attachment 229884 [details]
Patch
Comment 8 Dave Hyatt 2014-04-22 09:08:50 PDT
Fixed in r167663.