RESOLVED FIXED 131237
Use preallocated stack reference to store adjacentBacktrackingStart
https://bugs.webkit.org/show_bug.cgi?id=131237
Summary Use preallocated stack reference to store adjacentBacktrackingStart
Yusuke Suzuki
Reported 2014-04-04 12:14:40 PDT
Instead of using push / pop, allocate stack reference in prologue and store adjacentBacktrackingStart to it.
Attachments
Patch (11.06 KB, patch)
2014-04-04 12:29 PDT, Yusuke Suzuki
no flags
Patch (11.08 KB, patch)
2014-04-05 00:42 PDT, Yusuke Suzuki
no flags
Yusuke Suzuki
Comment 1 2014-04-04 12:29:31 PDT
Benjamin Poulain
Comment 2 2014-04-04 15:12:55 PDT
Comment on attachment 228614 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=228614&action=review Everything looks correct to me. CQ- because of two nitpicks. > Source/WebCore/cssjit/SelectorCompiler.cpp:210 > + bool m_needsAdjacentBacktrackingStart : 1; You should not use a bit field here. I would put the field just after m_selectorFragments since it is related to a global state of code generation. > Source/WebCore/cssjit/StackAllocator.h:63 > + StackReference push() The name push() is a bit misleading. I think allocate() or allocateUninitialized() would be better.
Yusuke Suzuki
Comment 3 2014-04-05 00:42:55 PDT
Yusuke Suzuki
Comment 4 2014-04-05 00:46:38 PDT
Comment on attachment 228614 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=228614&action=review Thank you for your review! I've fixed and attached revised patch. >> Source/WebCore/cssjit/SelectorCompiler.cpp:210 >> + bool m_needsAdjacentBacktrackingStart : 1; > > You should not use a bit field here. > > I would put the field just after m_selectorFragments since it is related to a global state of code generation. Thank you! You're right. I've removed a bit field. And moved m_needsAdjacentBacktrackingStart to just after m_selectorFragments. >> Source/WebCore/cssjit/StackAllocator.h:63 >> + StackReference push() > > The name push() is a bit misleading. I think allocate() or allocateUninitialized() would be better. Right. I've renamed it to allocateUninitialized.
Benjamin Poulain
Comment 5 2014-04-05 12:03:57 PDT
Comment on attachment 228665 [details] Patch Everything looks good to me.
WebKit Commit Bot
Comment 6 2014-04-05 12:32:25 PDT
Comment on attachment 228665 [details] Patch Clearing flags on attachment: 228665 Committed r166834: <http://trac.webkit.org/changeset/166834>
WebKit Commit Bot
Comment 7 2014-04-05 12:32:29 PDT
All reviewed patches have been landed. Closing bug.
Yusuke Suzuki
Comment 8 2014-04-06 21:53:57 PDT
Thank you!
Note You need to log in before you can comment on or make changes to this bug.