Bug 13121 - REGRESSION (r18288): getting value for hidden input element fails after the fix for Bug 11866
Summary: REGRESSION (r18288): getting value for hidden input element fails after the f...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Forms (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Critical
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-03-19 15:47 PDT by Jake Logan
Modified: 2007-03-23 12:58 PDT (History)
0 users

See Also:


Attachments
Test case from Comment #0 (596 bytes, text/html)
2007-03-19 17:40 PDT, David Kilzer (:ddkilzer)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jake Logan 2007-03-19 15:47:02 PDT
Please see reduction below. This issue is a regression caused by http://bugs.webkit.org/show_bug.cgi?id=11866.

<html>
<head>
	<script language="javascript">
		function showForm()
		{
			var frm = document.getElementById("frmChangeContent");
			frm.NavigationTarget.value = "Jake";
			alert(frm.innerHTML);
		}
		
	</script>
</head>
<body>
<FORM action="" method=POST id="frmChangeContent" name="frmChangeContent">
	<input type="hidden" id="NavigationTarget" name="NavigationTarget">
</FORM>

<input type = "button" value="Show Form innerHTML" onclick = "showForm()">
</body>
</html>
Comment 1 David Kilzer (:ddkilzer) 2007-03-19 17:40:30 PDT
Created attachment 13712 [details]
Test case from Comment #0
Comment 2 Maciej Stachowiak 2007-03-20 03:19:55 PDT
Does this affect a real-world site?
Comment 3 David Kilzer (:ddkilzer) 2007-03-20 04:19:21 PDT
(In reply to comment #2)
> Does this affect a real-world site?

Yes, see Bug 11866 Comment #10.

Comment 4 Adele Peterson 2007-03-23 11:40:32 PDT
Committed revision 20440
Comment 5 Darin Adler 2007-03-23 12:58:12 PDT
<rdar://problem/5080428>