Bug 13117 - REGRESSION (r14658): Flickering text fields when updating via javascript
Summary: REGRESSION (r14658): Flickering text fields when updating via javascript
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: mitz
URL: http://bestbefore.tv/flickr.html
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-03-19 06:30 PDT by Jonathan del Strother
Modified: 2007-03-19 12:46 PDT (History)
2 users (show)

See Also:


Attachments
Change -[WebCoreFrameBridge needsLayout] to consider pending subtree layout (2.92 KB, patch)
2007-03-19 08:35 PDT, mitz
no flags Details | Formatted Diff | Diff
Change -[WebCoreFrameBridge needsLayout] to consider pending subtree layout (2.92 KB, patch)
2007-03-19 08:36 PDT, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan del Strother 2007-03-19 06:30:29 PDT
Text fields often flicker when their value is set with javascript.  That is, when their value is changed, the field is cleared to white for a split second, then the actual value is drawn.  This is most obvious when they're rapidly updated (see the sample page) but can happen even for a single update.

The flicker seems to have been introduced between r14652:14663
Comment 1 mitz 2007-03-19 07:38:27 PDT
I think I know what to do!
Comment 2 mitz 2007-03-19 08:35:19 PDT
Created attachment 13704 [details]
Change -[WebCoreFrameBridge needsLayout] to consider pending subtree layout

The flickering was caused by painting without updating layout first, as a result of -[WebCoreFrameBridge needsLayout] returning NO because the required layout was for a subtree only.
Comment 3 mitz 2007-03-19 08:36:37 PDT
Created attachment 13705 [details]
Change -[WebCoreFrameBridge needsLayout] to consider pending subtree layout

Moved a *.
Comment 4 Maciej Stachowiak 2007-03-19 11:52:26 PDT
<rdar://problem/5072352>
Comment 5 Dave Hyatt 2007-03-19 12:41:29 PDT
Comment on attachment 13705 [details]
Change -[WebCoreFrameBridge needsLayout] to consider pending subtree layout

r=me
Comment 6 Adele Peterson 2007-03-19 12:46:33 PDT
Committed revision 20324.