Bug 130953 - REGRESSION: compositing/columns/composited-rl-paginated-repaint.html is flaky
Summary: REGRESSION: compositing/columns/composited-rl-paginated-repaint.html is flaky
Status: RESOLVED DUPLICATE of bug 128255
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-30 20:28 PDT by Alexey Proskuryakov
Modified: 2014-12-19 10:10 PST (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2014-03-30 20:28:41 PDT
compositing/columns/composited-rl-paginated-repaint.html became flaky on March 22nd (first failure was around r166116, but the culprit could easily be 20-30 revisions earlier).

History: http://webkit-test-results.appspot.com/dashboards/flakiness_dashboard.html#showAllRuns=true&tests=compositing%2Fcolumns%2Fcomposited-rl-paginated-repaint.html

Diff shows a missing repaint:

@@ -10,9 +10,6 @@
           (position 4.00 131.00)
           (bounds 130.00 130.00)
           (drawsContent 1)
-          (repaint rects
-            (rect 27.00 25.00 52.00 77.00)
-          )
         )
       )
     )
Comment 1 Alexey Proskuryakov 2014-03-30 20:30:44 PDT
Marked as flaky in <http://trac.webkit.org/r166472>.
Comment 2 Alexey Proskuryakov 2014-03-30 20:33:01 PDT
Perhaps r166117 (Don't flush compositing layers within FrameView::willPaintContents())?
Comment 3 Alexey Proskuryakov 2014-12-19 10:10:55 PST

*** This bug has been marked as a duplicate of bug 128255 ***