Bug 13089 - Suggested filename for standalone image includes dimensions and duplicate extension
Summary: Suggested filename for standalone image includes dimensions and duplicate ext...
Status: RESOLVED INVALID
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://webkit.org/images/icon-gold.png
Keywords: InRadar, Regression
: 13851 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-03-15 14:49 PDT by mitz
Modified: 2007-05-23 23:35 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mitz 2007-03-15 14:49:51 PDT
Summary:
The suggested filename when saving an image document includes, in addition to the filename, the image dimensions and an extra copy of the extension.

To reproduce:
1) Open the URL in Safari
2) Choose File > Save As

Expected results:
The default filename in the Save dialog to be "icon-gold.png"

Actual results:
The default filename in the Save dialog is "icon-gold.png 215×174 pixels.png"

Regression:
This is a regression from eliminating WebImageView.
Comment 1 Andrew Wellington 2007-03-25 04:36:48 PDT
This appears to be a Safari issue.

If [BrowserDocument filenameForSaving] were modified to ask for a suggested filename from the WebDataSource instead of/in addition to asking for the pageTitle this would give more flexibility in future for this sort of change or addition on the WebKit side.
Comment 2 mitz 2007-03-25 04:53:52 PDT
(In reply to comment #1)
> This appears to be a Safari issue.

Agreed. I planned to close this bug as INVALID after hearing the same from Anders, except I thought maybe I'd wait for someone to add the radar number first. I guess it's not really important.
Comment 3 Mark Rowe (bdash) 2007-03-25 05:10:06 PDT
<rdar://problem/5076037> REGRESSION: Suggested filename when saving standalone image now includes "n x n pixels".
Comment 4 mitz 2007-05-23 23:35:23 PDT
*** Bug 13851 has been marked as a duplicate of this bug. ***