Bug 130886 - [EFL] Bump glib version from 2.36 to 2.38
Summary: [EFL] Bump glib version from 2.36 to 2.38
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Gyuyoung Kim
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-03-27 22:03 PDT by Gyuyoung Kim
Modified: 2014-03-28 03:34 PDT (History)
5 users (show)

See Also:


Attachments
Patch (2.59 KB, patch)
2014-03-27 22:12 PDT, Gyuyoung Kim
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gyuyoung Kim 2014-03-27 22:03:02 PDT
There is a build break on EFL port when using glib 2.36 ver.

/home/gyuyoung/webkit/WebKit/WebKitBuild/Dependencies/Root/lib64/libgstapp-1.0.so.0: undefined reference to `g_type_class_adjust_private_offset'

The break comes from old glib version. We need to bump glib up to glib 2.38 version, which is used by gtk port.
Comment 1 Gyuyoung Kim 2014-03-27 22:12:10 PDT
Created attachment 228023 [details]
Patch
Comment 2 Csaba Osztrogonác 2014-03-28 02:58:32 PDT
Comment on attachment 228023 [details]
Patch

LGTM, r=me.
Comment 3 WebKit Commit Bot 2014-03-28 03:34:31 PDT
Comment on attachment 228023 [details]
Patch

Clearing flags on attachment: 228023

Committed r166403: <http://trac.webkit.org/changeset/166403>
Comment 4 WebKit Commit Bot 2014-03-28 03:34:37 PDT
All reviewed patches have been landed.  Closing bug.