[WK2] Getting rid of compilation warnings
Created attachment 226936 [details] Patch
Attachment 226936 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:54: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:61: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:67: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Total errors found: 3 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 226936 [details] Patch View in context: https://bugs.webkit.org/attachment.cgi?id=226936&action=review > Source/WebKit2/UIProcess/API/C/WKPage.cpp:705 > + UNUSED_PARAM(navigationID); > if (!m_client.didStartProvisionalLoadForFrame) In the implementation, you remove the name of the input argument instead of using UNUSED_PARAM(). For example, in this case, you should just remove navigationID.
Created attachment 226982 [details] Patch
Attachment 226982 [details] did not pass style-queue: ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:54: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:61: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] ERROR: Source/WebKit2/UIProcess/API/APIPolicyClient.h:67: The parameter type should use PassRefPtr instead of RefPtr. [readability/pass_ptr] [5] Total errors found: 3 in 8 files If any of these errors are false positives, please file a bug against check-webkit-style.
Comment on attachment 226982 [details] Patch Clearing flags on attachment: 226982 Committed r165794: <http://trac.webkit.org/changeset/165794>
All reviewed patches have been landed. Closing bug.