Bug 129272 - JSC regressions after r164494
Summary: JSC regressions after r164494
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh Intel Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 129281 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-24 13:41 PST by peavo
Modified: 2014-02-24 18:13 PST (History)
4 users (show)

See Also:


Attachments
Patch (1.61 KB, patch)
2014-02-24 14:05 PST, peavo
no flags Details | Formatted Diff | Diff
Patch (1.60 KB, patch)
2014-02-24 14:13 PST, peavo
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description peavo 2014-02-24 13:41:06 PST
The patch in bug 129155 caused many JSC test failures for 32-bit Mac and GTK.
Comment 1 peavo 2014-02-24 14:05:42 PST
Created attachment 225095 [details]
Patch
Comment 2 Geoffrey Garen 2014-02-24 14:11:24 PST
Comment on attachment 225095 [details]
Patch

r=me
Comment 3 peavo 2014-02-24 14:13:40 PST
Created attachment 225096 [details]
Patch
Comment 4 Mark Lam 2014-02-24 14:22:02 PST
Comment on attachment 225096 [details]
Patch

I don't know the x87 instructions, but In the original patch <http://trac.webkit.org/changeset/164494>, you modified all 3 cases in that if else statement blob.  Do the other 2 cases need to be conditional on isIntelSyntax as well?  Please comment.  Thanks.
Comment 5 peavo 2014-02-24 14:25:39 PST
(In reply to comment #4)
> (From update of attachment 225096 [details])
> I don't know the x87 instructions, but In the original patch <http://trac.webkit.org/changeset/164494>, you modified all 3 cases in that if else statement blob.  Do the other 2 cases need to be conditional on isIntelSyntax as well?  Please comment.  Thanks.

No, I believe I only added the orderOperands function there, which will do nothing for !isIntelSyntax.
Comment 6 Mark Lam 2014-02-24 14:31:06 PST
Comment on attachment 225096 [details]
Patch

r=me
Comment 7 WebKit Commit Bot 2014-02-24 14:53:17 PST
Comment on attachment 225096 [details]
Patch

Clearing flags on attachment: 225096

Committed r164612: <http://trac.webkit.org/changeset/164612>
Comment 8 WebKit Commit Bot 2014-02-24 14:53:19 PST
All reviewed patches have been landed.  Closing bug.
Comment 9 peavo 2014-02-24 14:55:26 PST
(In reply to comment #6)
> (From update of attachment 225096 [details])
> r=me

Thanks, sorry for the fuzz ...
Comment 10 Mark Hahnenberg 2014-02-24 18:13:37 PST
*** Bug 129281 has been marked as a duplicate of this bug. ***