Bug 129252 - REGRESSION(r164438): [GTK] Tests /webkit2/WebKitWebView/tls-errors-policy and /webkit2/WebKitWebContext/uri-scheme fail
Summary: REGRESSION(r164438): [GTK] Tests /webkit2/WebKitWebView/tls-errors-policy and...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit2 (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, Regression
Depends on:
Blocks:
 
Reported: 2014-02-24 02:14 PST by Carlos Garcia Campos
Modified: 2014-02-24 11:37 PST (History)
5 users (show)

See Also:


Attachments
Patch (1.95 KB, patch)
2014-02-24 05:50 PST, Enrique Ocaña
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Garcia Campos 2014-02-24 02:14:58 PST
/webkit2/WebKitWebContext/uri-scheme: **
ERROR:../../Tools/TestWebKitAPI/Tests/WebKit2Gtk/TestWebKitWebContext.cpp:225:void testWebContextURIScheme(URISchemeTest*, gconstpointer): assertion failed (test->m_error.get() == (test, 10)): Error message. (test, 399)

/webkit2/WebKitWebView/tls-errors-policy: **
ERROR:../../Tools/TestWebKitAPI/Tests/WebKit2Gtk/TestSSL.cpp:45:virtual void SSLTest::provisionalLoadFailed(const gchar*, GError*): assertion failed (error == (soup_http_error_quark, 6)): Unacceptable TLS certificate (soup_http_error_quark, 399)

This is because we are assuming all error codes come from WebCore. I think in the case of errors we should not use the conversion functions or at least we should not assert in default: and return the passed in error code instead of falling back to network error.
Comment 1 Enrique Ocaña 2014-02-24 05:50:54 PST
Created attachment 225056 [details]
Patch
Comment 2 WebKit Commit Bot 2014-02-24 05:53:18 PST
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment 3 Enrique Ocaña 2014-02-24 07:06:08 PST
The root cause of this bug is related to the root cause of #129256, but this time in WK2.
Comment 4 WebKit Commit Bot 2014-02-24 11:37:54 PST
Comment on attachment 225056 [details]
Patch

Clearing flags on attachment: 225056

Committed r164597: <http://trac.webkit.org/changeset/164597>
Comment 5 WebKit Commit Bot 2014-02-24 11:37:57 PST
All reviewed patches have been landed.  Closing bug.