It's a semi-private method but that it's only used once in WebKitWebViewBase.cpp and it contains a single line.
Created attachment 225032 [details]
Thanks for the patch. If this patch contains new public API please make sure it follows the guidelines for new WebKit2 GTK+ API. See http://trac.webkit.org/wiki/WebKitGTK/AddingNewWebKit2API
Comment on attachment 225032 [details]
Let's do it.
BTW what about also replacing the switch by an if statement in webkitWebViewBaseKeyPressEvent? Looks like abusing the syntax to me.
Committed r164578: <http://trac.webkit.org/changeset/164578>