Bug 12902 - Pressing return key doesn't move caret to next line after applying a font color in GMail
Summary: Pressing return key doesn't move caret to next line after applying a font col...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 523.x (Safari 3)
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Adele Peterson
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-02-26 15:33 PST by Adele Peterson
Modified: 2007-02-27 00:57 PST (History)
1 user (show)

See Also:


Attachments
test case (535 bytes, text/html)
2007-02-26 18:23 PST, Adele Peterson
no flags Details
patch (6.04 KB, patch)
2007-02-27 00:48 PST, Adele Peterson
lars.knoll: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Adele Peterson 2007-02-26 15:33:15 PST
* STEPS TO REPRODUCE
1. With TOT,  login to your gmail account
2. Create a rich text message
3. Choose a new font color from the tool palette.
4. Start type text in the message. With the caret at the end of this line, press the return key
5. Instead of a new line being created, the caret still remains at the current line

* RESULTS
The caret should move to the new line but doesn't
Comment 1 Adele Peterson 2007-02-26 15:33:58 PST
<rdar://problem/5012679> REGRESSION: Pressing return key doesn't move caret to next line after applying a font color in GMail

I broke this with my recent event handling change
Comment 2 Adele Peterson 2007-02-26 15:36:11 PST
Looks like after using the Font popup menu, the main frame is focused and the key event for the return key isn't sent to the editable subframe.

But the keys are still inserted because of code in Editor::insertText which calls selectionForEvent.

selectionForEvent is returning the selection for the page, not the frame.  Which I'm not sure is right.

But it seems like focus really should be getting set back to the iframe.  I'm not sure where that should happen though.
Comment 3 Adele Peterson 2007-02-26 18:23:41 PST
Created attachment 13388 [details]
test case
Comment 4 Adele Peterson 2007-02-27 00:48:21 PST
Created attachment 13390 [details]
patch
Comment 5 Adele Peterson 2007-02-27 00:57:23 PST
Committed revision 19879.