Bug 128622 - Make old-run-webkit-tests work with iOS Simulator WebKitTestRunner
Summary: Make old-run-webkit-tests work with iOS Simulator WebKitTestRunner
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: iPhone / iPad All
: P2 Normal
Assignee: David Farler
URL:
Keywords:
: 127693 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-11 13:41 PST by David Farler
Modified: 2014-02-21 15:25 PST (History)
12 users (show)

See Also:


Attachments
Patch (298.17 KB, patch)
2014-02-21 14:12 PST, David Farler
simon.fraser: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description David Farler 2014-02-11 13:41:28 PST
As a short-term effort, make old-run-webkit-tests work with WebKitTestRunner in the iOS simulator and add necessary features to WKTR to communicate results out of the simulator.
Comment 1 David Farler 2014-02-21 14:12:25 PST
Created attachment 224906 [details]
Patch
Comment 2 Simon Fraser (smfr) 2014-02-21 14:14:59 PST
Comment on attachment 224906 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=224906&action=review

I would suggesting doing the test result move in a separate commit from the script changes.

> Tools/Scripts/old-run-webkit-tests:130
> -sub installAndLaunchDumpRenderTreeAppUsingNotification($$);
> +sub installAndLaunchDumpToolAppUsingNotification($$);

I think you could use "TestRunnerApp" as the generic term.
Comment 3 David Farler 2014-02-21 15:00:13 PST
(In reply to comment #2)
> (From update of attachment 224906 [details])
> View in context: https://bugs.webkit.org/attachment.cgi?id=224906&action=review
> 
> I would suggesting doing the test result move in a separate commit from the script changes.

Sounds good. We were planning to scrap the results anyway and start over.

See: https://bugs.webkit.org/show_bug.cgi?id=129171

> 
> > Tools/Scripts/old-run-webkit-tests:130
> > -sub installAndLaunchDumpRenderTreeAppUsingNotification($$);
> > +sub installAndLaunchDumpToolAppUsingNotification($$);
> 
> I think you could use "TestRunnerApp" as the generic term.
Comment 4 David Farler 2014-02-21 15:21:06 PST
I don't think we need to test this ORWT change with Mac, since ORWT can only parse Skipped files or Test Expections files where each line is only a test path and assumes that any listing in either of those files is a "skip".

It does look like win-cairo uses this kind of TestExpectation file (one test path per line), however.
Comment 5 David Farler 2014-02-21 15:25:02 PST
Committed r164506: <http://trac.webkit.org/changeset/164506>
Comment 6 David Farler 2014-02-21 15:25:42 PST
*** Bug 127693 has been marked as a duplicate of this bug. ***