Bug 12818 - REGRESSION (r19148): shacknews.com does not render completely
Summary: REGRESSION (r19148): shacknews.com does not render completely
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.shacknews.com
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2007-02-19 15:10 PST by Antti Koivisto
Modified: 2007-02-21 19:10 PST (History)
1 user (show)

See Also:


Attachments
reduction (1.17 KB, text/html)
2007-02-20 10:40 PST, Antti Koivisto
no flags Details
Further reduction (1.09 KB, text/html)
2007-02-20 11:26 PST, mitz
no flags Details
Patch (83.16 KB, patch)
2007-02-21 01:37 PST, mitz
hyatt: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Koivisto 2007-02-19 15:10:44 PST
Only top part of the page is rendered. Works fine with Tiger WebKit.
Comment 1 mitz 2007-02-19 16:01:23 PST
The first time I clicked the link it rendered fine. The when I loaded it again it rendered only partially. Forcing a reload fixed it.
Comment 2 mitz 2007-02-19 16:03:35 PST
If I disable JavaScript, I can't reproduce the bug.
Comment 3 Jeff McGlynn 2007-02-19 18:35:40 PST
This bug only occurs occasionally, and when it does the rendering problem is fixed by resizing the window.  The source of the page doesn't cause it, so I believe the problem is due to a specific ad, most likely the skyscraper ad on the left of the page.
Comment 4 Antti Koivisto 2007-02-20 10:40:26 PST
Created attachment 13276 [details]
reduction

Here is a partial reduction. Changing almost anything on this page will make the bug disappear.

It still depends on an ad script from external server. Using local script hides the bug too.
Comment 5 mitz 2007-02-20 11:26:14 PST
Created attachment 13277 [details]
Further reduction

The green square doesn't appear until you force relayout (e.g. by resizing the window). Removing the intermediate layout (the document.body.offsetTop; line) makes the bug go away.
Comment 6 mitz 2007-02-20 11:36:10 PST
The test case works in r19136 but not in r19186.
Comment 7 mitz 2007-02-20 15:18:05 PST
I broke this in <http://trac.webkit.org/projects/webkit/changeset/19148> (fix for bug 10983). I have a patch here <http://paste.lisp.org/display/37138>.
Comment 8 mitz 2007-02-21 01:37:59 PST
Created attachment 13290 [details]
Patch
Comment 9 Dave Hyatt 2007-02-21 16:39:27 PST
Comment on attachment 13290 [details]
Patch

r=me
Comment 10 Sam Weinig 2007-02-21 19:10:05 PST
Landed in r19784.