Bug 12810 - REGRESSION (13355-13372): Left half of images is missing (zenfolio.com)
Summary: REGRESSION (13355-13372): Left half of images is missing (zenfolio.com)
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL: http://supermasj.zenfolio.com/p987404...
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-02-18 23:03 PST by Adam Roben (:aroben)
Modified: 2008-07-17 01:03 PDT (History)
4 users (show)

See Also:


Attachments
testcase that fails in both Safari 2.0.4 and ToT (381 bytes, text/html)
2007-02-18 23:04 PST, Adam Roben (:aroben)
no flags Details
testcase that behaves differently in 2.0.4 and ToT (4.34 KB, text/html)
2007-02-18 23:40 PST, Adam Roben (:aroben)
no flags Details
The One True Testcase (240 bytes, text/html)
2007-02-19 00:12 PST, Adam Roben (:aroben)
no flags Details
The One True Testcase (strict mode) (416 bytes, text/html)
2007-02-19 09:10 PST, Adam Roben (:aroben)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adam Roben (:aroben) 2007-02-18 23:03:40 PST
1/31/07 3:38 PM Stan Jirman:
Load this page:

http://supermasj.zenfolio.com/

You will see that the left half of all images is missing (see screen shot), incl. when you descend into the galleries. This is not in the spirit of the web site, and it shows up correctly in Firefox.

2/12/07 2:05 PM John Sullivan:
This essentially breaks the site, so I think it should be p1.

Sample URL: http://supermasj.zenfolio.com/p987404164/?session=0ED9EC291743042F&_not_a_link

2/18/07 9:43 PM Adam Roben:
This worked in r13354, and is broken in r13372. I'll try to narrow down further.

2/18/07 10:51 PM Adam Roben:
Attaching a reduced testcase
Comment 1 Adam Roben (:aroben) 2007-02-18 23:04:03 PST
<rdar://problem/4967757>
Comment 2 Adam Roben (:aroben) 2007-02-18 23:04:42 PST
Created attachment 13232 [details]
testcase that fails in both Safari 2.0.4 and ToT
Comment 3 Adam Roben (:aroben) 2007-02-18 23:07:50 PST
I'm suspicious of r13372 http://trac.webkit.org/projects/webkit/changeset/13372
Comment 4 Adam Roben (:aroben) 2007-02-18 23:11:08 PST
Gah, seems I've reduced too far. The attached testcase behaves the same in Safari 2.0.4 and ToT
Comment 5 Adam Roben (:aroben) 2007-02-18 23:11:55 PST
Note, however, that Safari and Firefox disagree on the rendering of the testcase.
Comment 6 Adam Roben (:aroben) 2007-02-18 23:40:41 PST
Created attachment 13234 [details]
testcase that behaves differently in 2.0.4 and ToT

Here's another reduction. This one shows different behavior in Safari 2.0.4 and ToT. However, I believe the original testcase still shows the bug, and shows that in some cases Safari 2.0.4 exhibited this buggy behavior.
Comment 7 Adam Roben (:aroben) 2007-02-18 23:46:51 PST
Comment on attachment 13234 [details]
testcase that behaves differently in 2.0.4 and ToT

If you replace the <link> tag in this testcase with the source of the css file it links to, 2.0.4 and ToT will agree on the rendering (but they'll still be different from Firefox).
Comment 8 Adam Roben (:aroben) 2007-02-19 00:12:18 PST
Created attachment 13235 [details]
The One True Testcase

Here we go. This testcase behaves the same in Firefox and Safari 2.0.4. ToT now respects overflow:hidden on elements with display:table as a result of r13372. It seems to me that ToT's behavior is correct.
Comment 9 Dave Hyatt 2007-02-19 01:33:08 PST
Is the site in quirks or strict mode?  We could consider a quirk if we're lucky enough that it is not in strict mode. :)

Comment 10 Adam Roben (:aroben) 2007-02-19 09:08:27 PST
(In reply to comment #9)
> Is the site in quirks or strict mode?  We could consider a quirk if we're lucky
> enough that it is not in strict mode. :)
> 

The site is in strict mode (although this isn't reflected by the testcase). I guess we chalk this up to a bug with the site, then?
Comment 11 Adam Roben (:aroben) 2007-02-19 09:10:01 PST
Created attachment 13239 [details]
The One True Testcase (strict mode)

Here's the same testcase in strict mode, for accuracy, showing the same behavior as in quirks mode in Safari 2.0.4, ToT, and Firefox.
Comment 12 Adam Roben (:aroben) 2007-02-19 14:03:42 PST
Turns out the One True Testcase is not to be believed. As far as I can tell, in Firefox there is no element that would be clipping the image, so this testcase does not accurately reflect the problem.
Comment 13 Adam Roben (:aroben) 2007-02-19 14:07:51 PST
Spoofing as Firefox results in the page rendering correctly. Safari is getting sent different CSS based on buggy Safari 2.0.4 behavior. ToT handles the CSS correctly, resulting in the images being clipped. Moving to Evangelism.
Comment 14 mitz 2007-02-19 14:14:53 PST
(In reply to comment #7)
> (From update of attachment 13234 [details] [edit])
> If you replace the <link> tag in this testcase with the source of the css file
> it links to, 2.0.4 and ToT will agree on the rendering (but they'll still be
> different from Firefox).
> 

It's worth noting here that this is because the website does UA sniffing. More importantly, when spoofing as Firefox 2, TOT WebKit renders the image correctly.
Comment 15 Sam Weinig 2007-02-19 14:55:16 PST
Lowering priority to P2 now that it is clear that this is an evangelism bug.
Comment 16 Robert Blaut 2008-02-11 02:50:59 PST
I don't the issue in Webkit r30123. Is it already fixed? Any confirmations?
Comment 17 Robert Blaut 2008-07-17 01:03:35 PDT
(In reply to comment #16)
> I don't the issue in Webkit r30123. Is it already fixed? Any confirmations?
> 

As I said a half year ago I don't see the issue on a reported page. Closing as fixed.