Bug 12805 - REGRESSION: suggestion popup has a disabled scroll bar
Summary: REGRESSION: suggestion popup has a disabled scroll bar
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: Regression
Depends on:
Blocks:
 
Reported: 2007-02-18 05:09 PST by Alexey Proskuryakov
Modified: 2007-02-22 07:46 PST (History)
1 user (show)

See Also:


Attachments
Force controls in the popup to appear active and eliminate some console spew (2.04 KB, patch)
2007-02-21 08:06 PST, mitz
mrowe: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Proskuryakov 2007-02-18 05:09:34 PST
Steps to reproduce:
1. Type something (for example, in a text field Bugzilla). The text should be short, to allow a lot of possible completions.
2. Press F5.

Results: a suggestion popup appears, but its scroll bar has a disabled look (though it does work).
Comment 1 mitz 2007-02-20 08:33:01 PST
AFAICT this is a regression only in the sense that in TOT it happens in text controls since they are engine-based. In editable HTML, the behavior is the same in Safari 2.0.4 (and in shipping Mail).
Comment 2 mitz 2007-02-21 08:06:13 PST
Created attachment 13297 [details]
Force controls in the popup to appear active and eliminate some console spew
Comment 3 Mark Rowe (bdash) 2007-02-21 23:58:38 PST
Comment on attachment 13297 [details]
Force controls in the popup to appear active and eliminate some console spew

r=me
Comment 4 Sam Weinig 2007-02-22 07:46:08 PST
Landed in r19789.