Bug 127904 - Fix compilation on ARM traditional after jsCStack branch merge
Summary: Fix compilation on ARM traditional after jsCStack branch merge
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: JavaScriptCore (show other bugs)
Version: 528+ (Nightly build)
Hardware: Other Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords:
: 127856 (view as bug list)
Depends on:
Blocks: 108645 127763
  Show dependency treegraph
 
Reported: 2014-01-30 03:52 PST by Pascal Jacquemart
Modified: 2014-01-31 07:06 PST (History)
6 users (show)

See Also:


Attachments
Speculative fix compilation for ARM traditional (1.30 KB, patch)
2014-01-30 03:58 PST, Pascal Jacquemart
no flags Details | Formatted Diff | Diff
Add missing pushPair/popPair implementations in macro assembler for traditional ARM. (1.54 KB, patch)
2014-01-31 06:12 PST, Julien Brianceau
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal Jacquemart 2014-01-30 03:52:18 PST
Speculative / untested patch to fix compilation for ARM traditional
Comment 1 Pascal Jacquemart 2014-01-30 03:58:09 PST
Created attachment 222658 [details]
Speculative fix compilation for ARM traditional
Comment 2 Csaba Osztrogonác 2014-01-30 04:34:36 PST
*** Bug 127856 has been marked as a duplicate of this bug. ***
Comment 3 Pascal Jacquemart 2014-01-31 03:38:30 PST
I tried to run on board but the build is crashing
In the meantime, it also crashed while disabling JIT at runtime so I might have another issue here ;-(
Comment 4 Julien Brianceau 2014-01-31 06:12:54 PST
Created attachment 222810 [details]
Add missing pushPair/popPair implementations in macro assembler for traditional ARM.

This one should work better :)
Comment 5 Zoltan Herczeg 2014-01-31 06:30:46 PST
Comment on attachment 222810 [details]
Add missing pushPair/popPair implementations in macro assembler for traditional ARM.

r=me
Comment 6 WebKit Commit Bot 2014-01-31 07:06:24 PST
Comment on attachment 222810 [details]
Add missing pushPair/popPair implementations in macro assembler for traditional ARM.

Clearing flags on attachment: 222810

Committed r163169: <http://trac.webkit.org/changeset/163169>
Comment 7 WebKit Commit Bot 2014-01-31 07:06:28 PST
All reviewed patches have been landed.  Closing bug.