Bug 127267 - AX: HTML5 media player focus styles are inconsistent; should use the same as the hover styles
Summary: AX: HTML5 media player focus styles are inconsistent; should use the same as ...
Status: RESOLVED DUPLICATE of bug 127260
Alias: None
Product: WebKit
Classification: Unclassified
Component: Accessibility (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: James Craig
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-19 23:33 PST by James Craig
Modified: 2014-02-19 01:16 PST (History)
1 user (show)

See Also:


Attachments
CSS diff that resolves most issues; need to test a little more (2.68 KB, patch)
2014-01-19 23:44 PST, James Craig
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Craig 2014-01-19 23:33:39 PST
AX: HTML5 media player focus styles are inconsistent; should use the same as the hover styles

This won't be entirely obvious until we get all the focus shadow DOM bugs fixed, but reproduction for now is this:

1. Load a video with captions and choose and item from the popup menu using a mouse (this will push a hidden focus back to the CC button)
2. Shift+Tab through the previous controls. Notice some use hidden outlines, some use native outlines, and some use the same as the hover states (subtle gradient backgrounds).

The focus styles should use mostly the same styles as the :active mouse states for now. Once bug 117857 is resolved, we can tweak the visual styles because they'll be easier to see.
Comment 1 Radar WebKit Bug Importer 2014-01-19 23:33:52 PST
<rdar://problem/15856681>
Comment 2 James Craig 2014-01-19 23:44:20 PST
Created attachment 221621 [details]
CSS diff that resolves most issues; need to test a little more
Comment 3 James Craig 2014-02-19 01:16:31 PST
Duping out to bug 127260

*** This bug has been marked as a duplicate of bug 127260 ***