Bug 127193 - Unprefix text-decoration CSS3 properties
Summary: Unprefix text-decoration CSS3 properties
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Myles C. Maxfield
URL:
Keywords: InRadar
: 123657 (view as bug list)
Depends on: 127333
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-17 15:25 PST by Myles C. Maxfield
Modified: 2018-11-08 14:19 PST (History)
23 users (show)

See Also:


Attachments
Patch (290.36 KB, patch)
2014-01-17 16:13 PST, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2 (244.47 KB, application/zip)
2014-01-17 17:00 PST, Build Bot
no flags Details
Archive of layout-test-results from webkit-ews-06 for mac-mountainlion (322.60 KB, application/zip)
2014-01-17 17:50 PST, Build Bot
no flags Details
Patch (144.49 KB, patch)
2014-01-21 12:26 PST, Myles C. Maxfield
no flags Details | Formatted Diff | Diff
Patch (16.30 KB, patch)
2018-11-06 18:15 PST, Myles C. Maxfield
dino: review+
ews: commit-queue-
Details | Formatted Diff | Diff
Archive of layout-test-results from ews107 for mac-sierra-wk2 (3.25 MB, application/zip)
2018-11-06 20:35 PST, Build Bot
no flags Details
Archive of layout-test-results from ews113 for mac-sierra (3.57 MB, application/zip)
2018-11-06 20:56 PST, Build Bot
no flags Details
Archive of layout-test-results from ews201 for win-future (12.85 MB, application/zip)
2018-11-06 21:55 PST, Build Bot
no flags Details
Archive of layout-test-results from ews102 for mac-sierra (2.65 MB, application/zip)
2018-11-06 21:58 PST, Build Bot
no flags Details
Archive of layout-test-results from ews121 for ios-simulator-wk2 (2.59 MB, application/zip)
2018-11-07 00:18 PST, Build Bot
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Myles C. Maxfield 2014-01-17 15:25:39 PST
Unprefix text-decoration CSS3 properties
Comment 1 Myles C. Maxfield 2014-01-17 16:13:02 PST
Created attachment 221507 [details]
Patch
Comment 2 Build Bot 2014-01-17 17:00:36 PST
Comment on attachment 221507 [details]
Patch

Attachment 221507 [details] did not pass mac-wk2-ews (mac-wk2):
Output: http://webkit-queues.appspot.com/results/4835051447517184

New failing tests:
editing/style/remove-underline-across-paragraph-in-bold.html
editing/execCommand/5190926.html
editing/style/inline-style-extend-run.html
editing/deleting/delete-line-break-before-underlined-content.html
editing/deleting/merge-div-from-span-with-style.html
editing/style/remove-nested-inline-styles.html
editing/style/push-down-implicit-styles-around-list-mac.html
editing/style/inline-style-container.html
editing/execCommand/strikethroughSelection.html
editing/pasteboard/insert-u-with-text-decoration-none.html
editing/execCommand/toggle-style-2.html
editing/pasteboard/5134759.html
editing/style/push-down-implicit-styles-around-list-win.html
editing/execCommand/remove-format-multiple-elements-win.html
editing/style/remove-underline-across-paragraph.html
editing/deleting/merge-paragraph-from-span-with-multiple-text-decoration.html
editing/style/font-family-with-space.html
editing/style/push-down-implicit-styles-mac.html
editing/pasteboard/5075944.html
editing/execCommand/remove-format-multiple-elements-mac.html
editing/execCommand/toggle-styles.html
editing/execCommand/query-text-decoration-with-typing-style.html
editing/execCommand/inline-style-after-indentoutdent.html
editing/execCommand/toggle-text-decorations.html
editing/execCommand/use-css.html
editing/deleting/merge-paragraph-from-span-with-style.html
editing/style/push-down-inline-styles.html
editing/execCommand/strikethrough-uses-strike-tag.html
editing/deleting/deleting-line-break-preserves-underline-color.html
editing/execCommand/remove-formatting.html
Comment 3 Build Bot 2014-01-17 17:00:41 PST
Created attachment 221513 [details]
Archive of layout-test-results from webkit-ews-14 for mac-mountainlion-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: webkit-ews-14  Port: mac-mountainlion-wk2  Platform: Mac OS X 10.8.5
Comment 4 Build Bot 2014-01-17 17:50:50 PST
Comment on attachment 221507 [details]
Patch

Attachment 221507 [details] did not pass mac-ews (mac):
Output: http://webkit-queues.appspot.com/results/6096580314660864

New failing tests:
editing/style/remove-underline-across-paragraph-in-bold.html
editing/execCommand/5190926.html
editing/style/inline-style-extend-run.html
editing/deleting/delete-line-break-before-underlined-content.html
editing/deleting/merge-div-from-span-with-style.html
editing/style/remove-nested-inline-styles.html
editing/style/push-down-implicit-styles-around-list-mac.html
editing/style/inline-style-container.html
editing/execCommand/strikethroughSelection.html
editing/pasteboard/insert-u-with-text-decoration-none.html
editing/execCommand/toggle-style-2.html
editing/pasteboard/5134759.html
editing/style/push-down-implicit-styles-around-list-win.html
editing/execCommand/remove-format-multiple-elements-win.html
editing/style/remove-underline-across-paragraph.html
editing/deleting/merge-paragraph-from-span-with-multiple-text-decoration.html
editing/style/font-family-with-space.html
editing/style/push-down-implicit-styles-mac.html
editing/pasteboard/5075944.html
editing/execCommand/remove-format-multiple-elements-mac.html
editing/execCommand/toggle-styles.html
editing/execCommand/query-text-decoration-with-typing-style.html
editing/style/remove-underline-after-paragraph-in-bold.html
editing/execCommand/inline-style-after-indentoutdent.html
editing/execCommand/toggle-text-decorations.html
editing/deleting/merge-paragraph-from-span-with-style.html
editing/style/push-down-inline-styles.html
editing/execCommand/strikethrough-uses-strike-tag.html
editing/deleting/deleting-line-break-preserves-underline-color.html
editing/execCommand/remove-formatting.html
Comment 5 Build Bot 2014-01-17 17:50:53 PST
Created attachment 221520 [details]
Archive of layout-test-results from webkit-ews-06 for mac-mountainlion

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: webkit-ews-06  Port: mac-mountainlion  Platform: Mac OS X 10.8.5
Comment 6 Sam Weinig 2014-01-19 11:54:54 PST
If we are truly ready to un-prefix these (and I am not sure we are), we should probably first remove the #ifdefs.
Comment 7 Myles C. Maxfield 2014-01-20 16:27:55 PST
*** Bug 123657 has been marked as a duplicate of this bug. ***
Comment 8 Myles C. Maxfield 2014-01-20 17:22:12 PST
<rdar://problem/15345417>
Comment 9 Myles C. Maxfield 2014-01-21 12:26:04 PST
Created attachment 221775 [details]
Patch
Comment 10 Jon Lee 2014-01-22 17:20:02 PST
The Radar assigned here conflicts with 127333.
Comment 11 Myles C. Maxfield 2014-01-22 18:15:48 PST
http://trac.webkit.org/changeset/162579
Comment 12 Myles C. Maxfield 2014-01-22 18:17:54 PST
Whoops, marked wrong bug
Comment 13 Myles C. Maxfield 2014-01-22 18:22:12 PST
If we're unprefixing text-decoration CSS properties, we should unprefix all of the text-decoration CSS properties.
Comment 14 Simon Pieters 2017-02-06 07:48:17 PST
WHATWG's standard.css now uses text-decoration-color (sans prefix), see https://github.com/whatwg/resources.whatwg.org/pull/45
Comment 15 Myles C. Maxfield 2018-11-06 17:45:24 PST
Looks like text-decoration and -webkit-text-decoration are distinct properties, with different semantics??? :(
Comment 16 Myles C. Maxfield 2018-11-06 18:15:32 PST
Created attachment 354039 [details]
Patch
Comment 17 Build Bot 2018-11-06 20:35:01 PST
Comment on attachment 354039 [details]
Patch

Attachment 354039 [details] did not pass mac-wk2-ews (mac-wk2):
Output: https://webkit-queues.webkit.org/results/9888376

New failing tests:
imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html
imported/blink/fast/css3-text/css3-text-decoration/text-decoration-line-recalc.html
imported/w3c/web-platform-tests/css/css-text-decor/text-decoration-line-recalc.html
Comment 18 Build Bot 2018-11-06 20:35:03 PST
Created attachment 354056 [details]
Archive of layout-test-results from ews107 for mac-sierra-wk2

The attached test failures were seen while running run-webkit-tests on the mac-wk2-ews.
Bot: ews107  Port: mac-sierra-wk2  Platform: Mac OS X 10.12.6
Comment 19 Build Bot 2018-11-06 20:56:16 PST
Comment on attachment 354039 [details]
Patch

Attachment 354039 [details] did not pass mac-debug-ews (mac):
Output: https://webkit-queues.webkit.org/results/9888296

New failing tests:
imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html
imported/w3c/web-platform-tests/css/css-text-decor/text-decoration-line-recalc.html
imported/blink/fast/css3-text/css3-text-decoration/text-decoration-line-recalc.html
Comment 20 Build Bot 2018-11-06 20:56:18 PST
Created attachment 354058 [details]
Archive of layout-test-results from ews113 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-debug-ews.
Bot: ews113  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 21 Build Bot 2018-11-06 21:55:42 PST
Comment on attachment 354039 [details]
Patch

Attachment 354039 [details] did not pass win-ews (win):
Output: https://webkit-queues.webkit.org/results/9888981

New failing tests:
imported/blink/fast/css3-text/css3-text-decoration/text-decoration-line-recalc.html
Comment 22 Build Bot 2018-11-06 21:55:54 PST
Created attachment 354060 [details]
Archive of layout-test-results from ews201 for win-future

The attached test failures were seen while running run-webkit-tests on the win-ews.
Bot: ews201  Port: win-future  Platform: CYGWIN_NT-6.1-2.10.0-0.325-5-3-x86_64-64bit
Comment 23 Build Bot 2018-11-06 21:58:20 PST
Comment on attachment 354039 [details]
Patch

Attachment 354039 [details] did not pass mac-ews (mac):
Output: https://webkit-queues.webkit.org/results/9889116

New failing tests:
imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html
imported/w3c/web-platform-tests/css/css-text-decor/text-decoration-line-recalc.html
imported/blink/fast/css3-text/css3-text-decoration/text-decoration-line-recalc.html
Comment 24 Build Bot 2018-11-06 21:58:22 PST
Created attachment 354062 [details]
Archive of layout-test-results from ews102 for mac-sierra

The attached test failures were seen while running run-webkit-tests on the mac-ews.
Bot: ews102  Port: mac-sierra  Platform: Mac OS X 10.12.6
Comment 25 Build Bot 2018-11-07 00:18:57 PST
Comment on attachment 354039 [details]
Patch

Attachment 354039 [details] did not pass ios-sim-ews (ios-simulator-wk2):
Output: https://webkit-queues.webkit.org/results/9890024

New failing tests:
imported/w3c/web-platform-tests/css/mediaqueries/test_media_queries.html
imported/w3c/web-platform-tests/css/css-text-decor/text-decoration-line-recalc.html
imported/blink/fast/css3-text/css3-text-decoration/text-decoration-line-recalc.html
Comment 26 Build Bot 2018-11-07 00:18:59 PST
Created attachment 354067 [details]
Archive of layout-test-results from ews121 for ios-simulator-wk2

The attached test failures were seen while running run-webkit-tests on the ios-sim-ews.
Bot: ews121  Port: ios-simulator-wk2  Platform: Mac OS X 10.13.6
Comment 27 Myles C. Maxfield 2018-11-08 14:18:25 PST
Committed r238002: <https://trac.webkit.org/changeset/238002>