Bug 127182 - Web Inspector: freeze when stopped at breakpoint and hovering over huge array
Summary: Web Inspector: freeze when stopped at breakpoint and hovering over huge array
Status: RESOLVED DUPLICATE of bug 143589
Alias: None
Product: WebKit
Classification: Unclassified
Component: Web Inspector (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2014-01-17 12:09 PST by bas
Modified: 2018-08-23 13:37 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description bas 2014-01-17 12:09:37 PST
Context:
I'm developing a financial charting application with WebGL. Huge datasets are displayed and handled (arrays containing up to 500,000 data points).

Issue:
When using the debugger and stopping at breakpoint or manually stepping, when you hover over a variable, a popup will show with the value of the variable. Great feature.
But, when hovering over one of those huge arrays, a popup will show up too, and even show "Array[<huge total>]" header in it, but the rest of the popup stays empty, the tab or window freezes and two processes peg 2 cores at 100%, each using 1,45GB memory (the processes are 'SafariForWebKitDevelopment Web Content' and 'Safari Web Content'). I can then only close the tab or window, the rest of the tab or window is frozen.

Expected behavior:
The first few entries in the array should show up in the popover.
Comment 1 Radar WebKit Bug Importer 2014-01-17 12:11:33 PST
<rdar://problem/15847944>
Comment 2 Brian Burg 2018-08-23 13:37:28 PDT

*** This bug has been marked as a duplicate of bug 143589 ***
Comment 3 Brian Burg 2018-08-23 13:37:50 PDT
We only fetch the first 100 entries, but this isn't great either.