Bug 12669 - REGRESSION: search box text does not get unselected during text input
Summary: REGRESSION: search box text does not get unselected during text input
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebCore Misc. (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-02-06 23:35 PST by Maciej Stachowiak
Modified: 2007-03-13 01:09 PDT (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maciej Stachowiak 2007-02-06 23:35:28 PST
2006-12-06 16:12:53 Stephanie Lewis:
Reason for clone:
Cloned Bug blocked because you cannot unselect the text in the search box

<original text: begin>

11/9/06 9:17 PM Masayuki Shibatani:
* SUMMARY
Seems Safari remembers recent typing on the fields on the site and fills the other fields with it as you stoke same spelling. It remains to show first few characters and as you typing continuously, it displays duplicate characters that you typed before.

* STEPS TO REPRODUCE
1. Install Leopard 9A305 on English primary, Japanese country region and Kotoeri as default keyboard.
2. Launch Safari.app.
3. Open URL: http://www.apple.com.
4. Click search field.
5. Select Hiragana input source.
6. Type 'umanomimininennbutu'. => Confirm you entered 'うまのみみにねんぶつ'.
7. Hit return key.
8. Click a new search field.
9. Select all and delete them.
10. Type 'uma'.
=> Confirm 'うま' unselected and follows 'のみみにねんぶつ' selected that are displayed, again. 
11. Type 'no'.

* RESULTS
Actual: 'うま' unselected and follows 'うまの' selected that are displayed. See attached the screen shot to know the result.

Expected: Should display 'うまの'.



</original text: end>

2006-12-06 16:12:54 Cloned from problemID rdar://problem/4830074 by: Stephanie Lewis.

2006-12-06 16:12:53 Stephanie Lewis:
Reason for clone:
Cloned Bug blocked because you cannot unselect the text in the search box.  In Leopard 9A319 you cannot complete step 10.  This is a regression from Safari 2.0.4

2006-12-07 04:49:04 David Harrison:
Rather, the original is blocked by this clone.

2006-12-11 14:03:24 Stephanie Lewis:
Safari BRB Reviewed

2007-01-15 14:20:00 Alice Liu:
Safari blocker reviewed

<rdar://problem/4868900>
Comment 1 Maciej Stachowiak 2007-03-13 01:09:58 PDT
Resolved in Radar.