Bug 12545 - Need to fix gradients to not need manual style resolve hack
Summary: Need to fix gradients to not need manual style resolve hack
Status: RESOLVED DUPLICATE of bug 12064
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-02-02 08:33 PST by Eric Seidel (no email)
Modified: 2007-06-12 10:29 PDT (History)
0 users

See Also:


Attachments
test case (407 bytes, image/svg+xml)
2007-02-02 08:34 PST, Eric Seidel (no email)
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eric Seidel (no email) 2007-02-02 08:33:57 PST
Need to fix gradients to not need manual style resolve hack

Currently gradient stops need manual style resolution in some cases (the attached test case is one).  It would be nice if we could remove the hack currently in place to make this possible.
Comment 1 Eric Seidel (no email) 2007-02-02 08:34:59 PST
Created attachment 12878 [details]
test case

put a break point in the manual style resolve hack and you'll see that it's used in this case.
Comment 2 Eric Seidel (no email) 2007-06-12 10:29:25 PDT

*** This bug has been marked as a duplicate of 12064 ***