Bug 12508 - REGRESSION (100-125): Safari 1.3 doesn't display the whole text of messages on bsh.co.il forums
Summary: REGRESSION (100-125): Safari 1.3 doesn't display the whole text of messages o...
Status: RESOLVED DUPLICATE of bug 3564
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tables (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.bsh.co.il/forums/AllMessag...
Keywords: HasReduction, InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-01-31 09:54 PST by Darin Adler
Modified: 2008-02-28 13:24 PST (History)
1 user (show)

See Also:


Attachments
Reduction (and several other test cases) (23.94 KB, text/html)
2007-01-31 10:53 PST, mitz
no flags Details
Reduction (and several other test cases) (4.68 KB, text/html)
2007-01-31 23:00 PST, mitz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2007-01-31 09:54:04 PST
<GMT15-Oct-2004 19:15:22GMT> Dary Mihova:
* SUMMARY: Safari on Tiger 8a268 doesn't display the whole messages on some forums with Hebrew text 

* STEPS TO REPRODUCE:
The problem is reproduced with Tiger 268.
Launch Safari.
Go to http://www.bsh.co.il/forums/AllMessages2.asp?Fnumber=21
The massages look like links (blue and underlined text). 
Click on one of the massage 

* RESULTS: 
 The text of the message is displayed but it is shifted to the right and part of it is hidden (marked with red square on the screenshot)

* REGRESSION: 
Open Safari 1.1.1 and follow the steps above -  The message gets opened.
Open Safari 1.2 and follow the steps above -  The text of the message is displayed but it is shifted to the right and part of it is hidden (marked with red square on the screenshot) - the same as Safari on Tiger 8a268.
Open Safari 1.3 and follow the steps above - the message won't open.
This problem was logged as 3716082 concerning the not opening links on Safari 1.3. Safari on Tiger 268 follows the behavior of Safari 1.2 - opens the links but doesn't display the whole text.

<GMT19-Oct-2004 20:42:49GMT> Christopher Hansten:
Intl BRB: Given the regression, this appears to be broken functionality that was working in 1.1.1 (and partially working in 1.2). In that light, could be a general problem. However, looking at the related bug, this appears to not be intl specific (assuming same underlying cause). 

<GMT21-Oct-2004 21:20:41GMT> Dave Hyatt:
Needs a reduction.  The HTML is a malformed mess, so it's hard to tell what's going on.


<GMT01-Dec-2004 23:48:54GMT> Kurt Knight:
Bidi support is also a marketing priority. Darin - please touch base with me if you have questions about prioritization.

<GMT11-Dec-2004 01:49:09GMT> Jill Surdzial:
Reviewed by Intl BRB 12/9/04.

<GMT14-Dec-2004 23:29:44GMT> Kim Koefoed Vorrath:
Safari BRB reviewed.

<GMT18-Jan-2005 22:25:19GMT> Kim Koefoed Vorrath:
Safari BRB:  Moving to Later.

<rdar://problem/3841630>
Comment 1 mitz 2007-01-31 10:10:29 PST
<http://www.bsh.co.il/forums/AllMessages2.asp?Fnumber=169> is a working URL that demonstrates the bug.
Comment 2 mitz 2007-01-31 10:53:42 PST
Created attachment 12828 [details]
Reduction (and several other test cases)

Looks like a table layout bug. In the very first case, there is also a painting bug (but the area that's not painting should not be part of the layout).
Comment 3 mitz 2007-01-31 23:00:45 PST
Created attachment 12849 [details]
Reduction (and several other test cases)

Oops, this is what I intended to upload. Note that the bug has nothing to do with Hebrew (or text).
Comment 4 mitz 2008-02-28 13:24:06 PST

*** This bug has been marked as a duplicate of 3564 ***