Bug 12505 - Hebrew list style type is not RTL
Summary: Hebrew list style type is not RTL
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Text (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2007-01-31 09:43 PST by Darin Adler
Modified: 2007-01-31 20:58 PST (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darin Adler 2007-01-31 09:43:14 PST
<GMT14-Apr-2003 16:33:00GMT> Avi Drissman:
* SUMMARY 
There is a CSS style for <ol> elements, list-style-type, which allows for a numbering style. If that attribute is set to "hebrew", the hebrew numbers are not RTL.

* STEPS TO REPRODUCE 
1. Go to http://homepage.mac.com/avidrissman/testcases/hebrewlist.html

* RESULTS
The first ten items in the list have one-letter labels, so they are fine. But starting with the eleventh, the labels now consist of two letters, which should be displayed RTL. They are not.

* REGRESSION
This has been present since the earliest builds of Safari.

* NOTES
none

<GMT14-Apr-2003 18:12:56GMT> ZEENAT SUBEDAR:
Please assign to Developer ADC Bugs for further communication with the  developer.
 

<GMT07-Jun-2003 00:00:56GMT> Shelley Sheridan:
attached screenshot comparing with Mozilla, which also puts the period before the number instead of after.

<rdar://problem/3227438>
Comment 1 mitz 2007-01-31 10:18:26 PST
I can't be 100% sure without the original test case, but I think this is fixed in TOT and probably in the latest shipping version of Tiger.