Bug 124421 - [Mac][AVF] Allow video and audio tracks to be initialized with an AVAssetTrack.
Summary: [Mac][AVF] Allow video and audio tracks to be initialized with an AVAssetTrack.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Jer Noble
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-15 10:13 PST by Jer Noble
Modified: 2013-11-15 15:59 PST (History)
3 users (show)

See Also:


Attachments
Patch (15.21 KB, patch)
2013-11-15 10:16 PST, Jer Noble
eric.carlson: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jer Noble 2013-11-15 10:13:17 PST
[Mac][AVF] Allow video and audio tracks to be initialized with an AVAssetTrack.
Comment 1 Jer Noble 2013-11-15 10:16:54 PST
Created attachment 217060 [details]
Patch
Comment 2 Eric Carlson 2013-11-15 11:59:08 PST
Comment on attachment 217060 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=217060&action=review

As we discussed on irc, the methods that require an AVPlayerItem should ASSERT when the track doesn't have one.

> Source/WebCore/ChangeLog:4182
> +2013-11-12  Jer Noble  <jer.noble@apple.com>
> +
> +        Add support for HTMLMediaElement.fastSeek()
> +        https://bugs.webkit.org/show_bug.cgi?id=124262

Oops!
Comment 3 Jer Noble 2013-11-15 15:59:59 PST
Committed r159368: <http://trac.webkit.org/changeset/159368>