Bug 12410 - REGRESSION: Focus ring obscured by overflow: hidden
Summary: REGRESSION: Focus ring obscured by overflow: hidden
Status: RESOLVED WONTFIX
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Trivial
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2007-01-25 21:27 PST by Devin Chalmers
Modified: 2007-04-30 01:36 PDT (History)
1 user (show)

See Also:


Attachments
reduction for focus ring obfuscation (466 bytes, text/html)
2007-01-25 21:27 PST, Devin Chalmers
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Devin Chalmers 2007-01-25 21:27:09 PST
When an input element with 100% width is placed inside an unpadded div with to overflow: hidden, the focus ring around the element is obscured by the edges of the div.

It is possible that this is by design, to fit with the CSS rule to hide overflow on the div. But it seems logical that, for accessibility reasons, the focus ring should not be obscured by any page elements. Otherwise, web pages could obscure the focus ring altogether.

Noticed at http://www.avclub.com/content/node/57616 .

Tested on nightly build r19107, Thu Jan 25 6:27:48 GMT 2007.
Comment 1 Devin Chalmers 2007-01-25 21:27:54 PST
Created attachment 12676 [details]
reduction for focus ring obfuscation
Comment 2 Alexey Proskuryakov 2007-04-25 06:19:43 PDT
Confirmed as a regression.
Comment 3 Mark Rowe (bdash) 2007-04-27 03:01:33 PDT
<rdar://problem/5166151>
Comment 4 Dave Hyatt 2007-04-27 03:11:29 PDT
This is working as intended.
Comment 5 Mark Rowe (bdash) 2007-04-30 01:36:02 PDT
Closing due to Dave's comments in comment #4.