Bug 12331 - REGRESSION(r18951): Selecting text in a textarea makes the page scroll
Summary: REGRESSION(r18951): Selecting text in a textarea makes the page scroll
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Darin Adler
URL:
Keywords: InRadar, Regression
: 12348 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-01-18 18:27 PST by Daniele Metilli
Modified: 2007-01-24 21:04 PST (History)
4 users (show)

See Also:


Attachments
patch, no change log or layout test (can someone write a test?) (898 bytes, patch)
2007-01-21 18:03 PST, Darin Adler
mjs: review-
Details | Formatted Diff | Diff
beginning of layout test (1.50 KB, text/html)
2007-01-24 13:53 PST, Adele Peterson
no flags Details
patch, this time with change log and layout test (28.06 KB, patch)
2007-01-24 20:48 PST, Darin Adler
adele: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniele Metilli 2007-01-18 18:27:27 PST
After r18951 (the fix for "flashy" selection in textareas), if you select some text in a textarea the page scrolls up. You can try this here in Bugzilla:

1 - Scroll down (a scroll bar must appear in the window).
2 - Type something in the textarea and select it.
3 - The page scrolls up.

I have found this bug using a trackpad, so I'm not sure it's the same with a mouse.
If it's trackpad-specific, it may also be related to bug 10747.
Comment 1 Matt Lilek 2007-01-18 18:36:33 PST
Not trackpad specific, happens with my mouse too.
Comment 2 mitz 2007-01-20 22:32:59 PST
*** Bug 12348 has been marked as a duplicate of this bug. ***
Comment 3 David Kilzer (:ddkilzer) 2007-01-21 05:49:04 PST
Also happens in text fields.

Comment 4 Darin Adler 2007-01-21 18:03:57 PST
Created attachment 12591 [details]
patch, no change log or layout test (can someone write a test?)
Comment 5 Mark Rowe (bdash) 2007-01-21 19:56:00 PST
<rdar://problem/4944774>
Comment 6 Maciej Stachowiak 2007-01-22 18:58:21 PST
Comment on attachment 12591 [details]
patch, no change log or layout test (can someone write a test?)

r- for lack of test case. Probably possible to make one with eventSender.
Comment 7 Adele Peterson 2007-01-24 13:53:17 PST
Created attachment 12648 [details]
beginning of layout test

I started this layout test.  But I just can't seem to trigger autoscroll with the eventSender.
Comment 8 Darin Adler 2007-01-24 20:48:11 PST
Created attachment 12658 [details]
patch, this time with change log and layout test
Comment 9 Darin Adler 2007-01-24 21:04:42 PST
Committed revision 19102.