Bug 123149 - Fix some more code to use RenderElement instead of RenderObject.
Summary: Fix some more code to use RenderElement instead of RenderObject.
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Andreas Kling
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-10-22 04:20 PDT by Andreas Kling
Modified: 2013-10-22 06:10 PDT (History)
4 users (show)

See Also:


Attachments
Patch (7.29 KB, patch)
2013-10-22 04:20 PDT, Andreas Kling
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Kling 2013-10-22 04:20:11 PDT
I have a patch tightening some parts of RenderElement.cpp
Comment 1 Andreas Kling 2013-10-22 04:20:43 PDT
Created attachment 214837 [details]
Patch
Comment 2 Antti Koivisto 2013-10-22 05:36:19 PDT
Comment on attachment 214837 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=214837&action=review

> Source/WebCore/rendering/RenderElement.cpp:794
> +static inline bool rendererHasBackground(const RenderElement* renderer)
>  {
>      return renderer && renderer->hasBackground();
>  }

Reference
Comment 3 WebKit Commit Bot 2013-10-22 06:10:24 PDT
Comment on attachment 214837 [details]
Patch

Clearing flags on attachment: 214837

Committed r157788: <http://trac.webkit.org/changeset/157788>
Comment 4 WebKit Commit Bot 2013-10-22 06:10:26 PDT
All reviewed patches have been landed.  Closing bug.