Bug 12144 - REGRESSION(?): CSS3 selector test site no longer works
Summary: REGRESSION(?): CSS3 selector test site no longer works
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P1 Normal
Assignee: Nobody
URL: http://www.css3.info/selectors-test/t...
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-06 14:37 PST by Hanspeter Schaub
Modified: 2007-01-07 00:24 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hanspeter Schaub 2007-01-06 14:37:53 PST
The CSS3 selector test site at

http://www.css3.info/selectors-test/test.html

no longer functions?  This worked just a few days ago.  I don't know javascript, so I am not able to reduce this bug to  a simpler test case.  The Terminal window does show the error message

(timer):Undefined value

when I try to access this test site.
Comment 1 Matt Lilek 2007-01-06 15:41:18 PST
Confirmed with r18640.
Comment 2 Alexey Proskuryakov 2007-01-06 16:32:31 PST
I'm getting the same error from shipping Safari, so it looks like the site itself may have changed.
Comment 3 Hanspeter Schaub 2007-01-06 16:35:48 PST
(In reply to comment #2)
> I'm getting the same error from shipping Safari, so it looks like the site
> itself may have changed.
> 

I know the nightly builds worked just fine on this site last weekend.  Firefox 2.0 continues to work.  Not sure what has changes in webkit or the site?

Comment 4 Joost de Valk (AlthA) 2007-01-07 00:11:54 PST
Hmm i fucked it up, will fix!
Comment 5 Joost de Valk (AlthA) 2007-01-07 00:24:50 PST
Resolved, yet, this code:

<script type="text/javascript">
<!--
  if (document.referrer != "http://www.css3.info/selectors-test/test.html") {
    document.location = "http://www.css3.info/selectors-test/";
  }
-->
</script>

seemed to interfere with the working of the script, it didn't in Firefox... can't reproduce it reliably though.