Bug 118900 - Code refactoring: parsing of MathML lengths
Summary: Code refactoring: parsing of MathML lengths
Status: RESOLVED DUPLICATE of bug 156536
Alias: None
Product: WebKit
Classification: Unclassified
Component: MathML (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on: 156792
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-19 05:50 PDT by Frédéric Wang (:fredw)
Modified: 2016-07-11 07:33 PDT (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frédéric Wang (:fredw) 2013-07-19 05:50:21 PDT
Follow-up of bug 118053 comment 19.

The MathML code could be more consistent with what the CSS parsing does and could rely on some of the existing parsing functions (e.g. conversionToCanonicalUnitsScaleFactor from CSSPrimitiveValue.cpp).

This could help making LayoutTests/mathml/presentation/mspace-units.html pass on Mac.
Comment 1 Frédéric Wang (:fredw) 2016-07-11 07:33:48 PDT
I'm merging this into bug 156536 which includes more than just length attributes.

*** This bug has been marked as a duplicate of bug 156536 ***