Bug 11872 - Air Canada, browser warning
Summary: Air Canada, browser warning
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Evangelism (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P4 Normal
Assignee: Nobody
URL: http://www.aircanada.com/en/home.html
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-19 04:11 PST by David Storey
Modified: 2008-02-10 15:49 PST (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Storey 2006-12-19 04:11:47 PST
Warns against Safari (and Opera) on each page.

Web Site contact form:  http://aircanada.custhelp.com/cgi-bin/aircanada.cfg/php/enduser/ask.php?p_sid=z3UPiFrh&p_lva=&p_sp=cF9zcmNoPSZwX2dyaWRzb3J0PSZwX3Jvd19jbnQ9MTY4JnBfcGFnZT0x&p_li=

Site seems to work fine (although I haven't booked a flight) in both Safari and Opera.
Comment 1 David Kilzer (:ddkilzer) 2006-12-19 06:17:16 PST
Confirmed using locally build debug build of WebKit r18306 with Safari 2.0.4 (419.3) on Mac OS X 10.4.8 (8L127).

Comment 2 Gilles Gauthier 2007-11-02 19:29:28 PDT
I just wanted to note that I recently did try to book a flight with WebKit (r26989, Oct 24, 2007) on Mac OS X 10.4.10 with Safari 3 Beta installed. It mostly worked, except if you try to choose your own seats. In that case, it appeared to work (I received the selection window and made my choices, which appeared on the order page), but did not take effect when trying to proceed with the order. Worked fine in Firefox. Because a flight purchase is required to reproduce, I was only able to do it the once.
Comment 3 Robert Blaut 2008-02-10 15:49:15 PST
I've tested this site today with Webkit r30123 and the site does not warn against Safari. However Opera is still unsupported.