Bug 118421 - [GTK] [Debug] [Crash] Layout Test fast/repaint/fixed-right-bottom-in-page-scale.html is failing
Summary: [GTK] [Debug] [Crash] Layout Test fast/repaint/fixed-right-bottom-in-page-sca...
Status: RESOLVED DUPLICATE of bug 118238
Alias: None
Product: WebKit
Classification: Unclassified
Component: Tools / Tests (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Nobody
URL:
Keywords: Gtk, LayoutTestFailure
Depends on:
Blocks:
 
Reported: 2013-07-05 09:13 PDT by Simon Pena
Modified: 2013-07-09 09:17 PDT (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Simon Pena 2013-07-05 09:13:47 PDT
The following layout test is failing on GTK Debug

fast/repaint/fixed-right-bottom-in-page-scale.html

It started crashing in r151805
Comment 2 Simon Pena 2013-07-08 03:29:55 PDT
I'm taking a look at this one. It actually started crashing in the 151805..151800 range.
Comment 3 Simon Pena 2013-07-09 02:12:47 PDT
This is crashing here:

ASSERTION FAILED: m_repaintRect == renderer()->clippedOverflowRectForRepaint(renderer()->containerForRepaint())
../../Source/WebCore/rendering/RenderLayer.cpp(810) : void WebCore::RenderLayer::updateLayerPositionsAfterScroll(WebCore::RenderGeometryMap*, WebCore::RenderLayer::UpdateLayerPositionsAfterScrollFlags)

This happens after the changes from http://trac.webkit.org/changeset/151803.

I debugged this, and when m_nestedLayerCount is 1, the m_repaintRect hasn't been updated yet, and the assertions fail.

I'm CCing Simon to see if he can suggest anything.
Comment 4 Simon Fraser (smfr) 2013-07-09 09:00:04 PDT
Bug 118238 covers this same assertion.
Comment 5 Simon Pena 2013-07-09 09:17:20 PDT
We can then close this as a duplicate.

*** This bug has been marked as a duplicate of bug 118238 ***