Bug 11601 - REGRESSION (r13354-r13372): Items relative to fixed div move/cease functioning when page scrolls
Summary: REGRESSION (r13354-r13372): Items relative to fixed div move/cease functionin...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: CSS (show other bugs)
Version: 420+
Hardware: Macintosh PowerPC OS X 10.4
: P1 Major
Assignee: Nobody
URL: http://test.nationalsalute.com/
Keywords: HasReduction, Regression
Depends on:
Blocks:
 
Reported: 2006-11-15 07:48 PST by Kevin M. Dean
Modified: 2007-01-01 17:36 PST (History)
1 user (show)

See Also:


Attachments
Reduction (4.48 KB, text/html)
2006-11-15 08:34 PST, Kevin M. Dean
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2006-11-15 07:48:07 PST
The above link is a site currently in development so other elements may get funky from time to time.

When viewing the above page as it initially opens, rollover the top navigation and you'll see I have a sub-menu nav working. If you shorten the height of your browser so that a vertical scroll appears, scroll the page down and then try to use the menu. The image rollovers (macromedia swap style) and the submenu divs no longer appear. If you scroll down the page quickly while a submenu is visible, you'll see the submenu move upwards off the screen when it shouldn't move at all.

Works correctly in Safari, Firefox and IE 7 (IE 6 doesn't use the fixed position since it doesn't support it).
Comment 1 Kevin M. Dean 2006-11-15 08:05:18 PST
This appears to be an oldy from back in March.

Works fine with Nightly r13354, breaks with Nightly r13372
Comment 2 Kevin M. Dean 2006-11-15 08:34:23 PST
Created attachment 11526 [details]
Reduction
Comment 3 Kevin M. Dean 2006-11-15 08:36:25 PST
Oops, forgot about the images when adding my reduction attachment. You can also look at the reduction here: http://development.rhubarbproductions.com/webkit/test.html
Comment 4 mitz 2006-11-15 08:55:49 PST
The "scrolling off the screen" part looks like bug 8788, although that bug is not a regression.
Comment 5 Kevin M. Dean 2006-11-15 09:07:32 PST
It does seem similar/related to bug 8788. For instance if I resize the browser after scrolling it off, it reappears. If I rollover a button while scrolled down and then resize, the rollover then reappears. So, it's seems tied to repaint issues .
Comment 6 Kevin M. Dean 2006-11-15 09:09:15 PST
I just read on the other bug:

"I don't think this is a repaint bug. Forcing a repaint (by switching to a
different tab) doesn't clear the problem. Resizing does, but that also does a
layout."

My test works in the same fashion and is not cleared by a tab switch, so maybe it's not a paint issue.
Comment 7 mitz 2006-11-15 09:35:57 PST
Yeah, I don't think either bug is a repaint bug. It's likely that r13372 (fix for bug 7841) made this bug's test case susceptible to bug 8788.
Comment 8 Kevin M. Dean 2006-12-12 05:34:48 PST
Just checking in to see if anyone has started to take a look at this issue (and the probably related bug 8788 / 9659). It would be really problematic if it lasts to the release version.
Comment 9 Kevin M. Dean 2007-01-01 17:36:23 PST
Patch for Bug 9659 also resolves this issue.