Bug 115685 - Reproducible crash in RenderBoxModelObject::adjustedPositionRelativeToOffsetParent()
Summary: Reproducible crash in RenderBoxModelObject::adjustedPositionRelativeToOffsetP...
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: Layout and Rendering (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: Beth Dakin
URL:
Keywords: InRadar
Depends on:
Blocks:
 
Reported: 2013-05-06 17:17 PDT by Beth Dakin
Modified: 2013-05-06 17:32 PDT (History)
6 users (show)

See Also:


Attachments
Patch (7.54 KB, patch)
2013-05-06 17:30 PDT, Beth Dakin
sam: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Beth Dakin 2013-05-06 17:17:29 PDT
This website crashes http://www.hodinkee.com/blog/twixt-time-evaluate-the-accuracy-of-your-watch-right-on-your-iphone

0   com.apple.WebCore             	0x00000001064c0797 WebCore::RenderBoxModelObject::adjustedPositionRelativeToOffsetParent(WebCore::LayoutPoint const&) const + 391
1   com.apple.WebCore             	0x00000001064bd63f WebCore::RenderBox::offsetLeft() const + 111
2   com.apple.WebCore             	0x0000000105b0ed6d WebCore::Element::offsetLeft() + 61
3   com.apple.WebCore             	0x00000001062583ed WebCore::jsElementOffsetLeft(JSC::ExecState*, JSC::JSValue, 

This is a regression that was caused by http://trac.webkit.org/changeset/147395

<rdar://problem/13700734>
Comment 1 Beth Dakin 2013-05-06 17:30:13 PDT
Created attachment 200858 [details]
Patch
Comment 2 Sam Weinig 2013-05-06 17:31:07 PDT
Comment on attachment 200858 [details]
Patch

View in context: https://bugs.webkit.org/attachment.cgi?id=200858&action=review

> Source/WebCore/rendering/RenderObject.h:662
> +    RenderBoxModelObject* offsetParent() const; 

SPACE!!!!!
Comment 3 WebKit Commit Bot 2013-05-06 17:31:31 PDT
Attachment 200858 [details] did not pass style-queue:

Failed to run "['Tools/Scripts/check-webkit-style', '--diff-files', u'Source/WebCore/ChangeLog', u'Source/WebCore/dom/Element.cpp', u'Source/WebCore/rendering/RenderBoxModelObject.cpp', u'Source/WebCore/rendering/RenderObject.cpp', u'Source/WebCore/rendering/RenderObject.h']" exit_code: 1
Source/WebCore/rendering/RenderObject.cpp:3011:  Weird number of spaces at line-start.  Are you using a 4-space indent?  [whitespace/indent] [3]
Total errors found: 1 in 5 files


If any of these errors are false positives, please file a bug against check-webkit-style.
Comment 4 Beth Dakin 2013-05-06 17:32:43 PDT
Thanks Sam! http://trac.webkit.org/changeset/149653