Bug 11512 - [Drosera] Scrolling via keyboard breaks after clicking in function popup
Summary: [Drosera] Scrolling via keyboard breaks after clicking in function popup
Status: CLOSED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-03 21:23 PST by Mark Rowe (bdash)
Modified: 2008-05-17 09:56 PDT (History)
0 users

See Also:


Attachments
Should fix this issue (1.15 KB, patch)
2006-11-04 00:10 PST, David Smith
timothy: review+
Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2006-11-03 21:23:04 PST
Steps to reproduce:

1) Open Drosera, attach to WebKit.
2) Browse to google.com
3) Switch to Drosera, click on the function popup and select "sf()"
4) Click in the source view, and hit the Down arrow on your keyboard to scroll down.

Expected results:
Source view scrolls down.

Actual Results:
Function popup menu appears.
Comment 1 David Smith 2006-11-04 00:10:09 PST
Created attachment 11373 [details]
Should fix this issue

It may appear, in testing this, that it breaks the function popup. This appears to be another bug that existed before the patch, which I will file in a moment if it hasn't already been filed. It can be worked around by clicking exactly where the value in the popup menu will be when it shows.
Comment 2 Mark Rowe (bdash) 2006-11-04 22:20:27 PST
Landed in r17600.
Comment 3 Timothy Hatcher 2008-05-17 09:56:00 PDT
Closing since Drosera has been replaced by the new Web Inspector debugger. Moving to the New Bugs component so the Drosera component can be closed and removed.