Bug 11409 - REGRESSION(r17276): Assertion failure during layout tests
Summary: REGRESSION(r17276): Assertion failure during layout tests
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: HTML Editing (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Major
Assignee: Nobody
URL:
Keywords: InRadar, Regression
Depends on:
Blocks:
 
Reported: 2006-10-24 19:30 PDT by Mark Rowe (bdash)
Modified: 2012-06-03 00:17 PDT (History)
4 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Rowe (bdash) 2006-10-24 19:30:32 PDT
WebCore/dom/Position.cpp:332: failed assertion `currentOffset >= renderer->caretMaxOffset()'

The assertion fails during editing/pasteboard, possibly in editing/pasteboard/copy-paste-bidi.html.
Comment 1 mitz 2006-10-24 23:51:39 PDT
The assert was commented out in r17279.
Comment 2 Alexey Proskuryakov 2006-10-25 01:49:07 PDT
See also: bug 8855. I'm not sure why this started happenning during layout tests.
Comment 3 Stephanie Lewis 2006-11-08 15:10:24 PST
radar 4826918
Comment 4 Maciej Stachowiak 2007-02-26 11:52:21 PST
Downgrading to P2 since animation is no longer on by default.
Comment 5 Maciej Stachowiak 2007-02-26 14:12:58 PST
This is not the bug I was looking for. Back to P1.
Comment 6 Oliver Hunt 2007-07-13 21:38:53 PDT
no longer a p1 -- see radar

Also, i can't repro this...
Comment 7 Oliver Hunt 2007-07-13 23:04:03 PDT
from mark, the reason i can't repro is because the assertion is disabled
Comment 8 Oliver Hunt 2007-07-14 00:17:37 PDT
sorry, for radarless people -- it's not a p1 as it is not obvously harmful, although it is certainly less than ideal it is not bad enough to be a p1
Comment 9 Ryosuke Niwa 2012-06-03 00:17:00 PDT
I don't think this assertion / commented-out assertion exists anymore.