Bug 11364 - data:,foo doesn't get text/plain MIME type
Summary: data:,foo doesn't get text/plain MIME type
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh OS X 10.4
: P2 Normal
Assignee: Nobody
URL: data:,This%20is%20a%20text%20file
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-19 17:52 PDT by Ian 'Hixie' Hickson
Modified: 2008-07-16 03:15 PDT (History)
3 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 'Hixie' Hickson 2006-10-19 17:52:09 PDT
data:,foo is shorthand for data:text/plain,foo but in Webkit that doesn't work.
Comment 1 Robert Blaut 2008-07-16 02:52:24 PDT
As I tested today the bug seems to be already fixed in Webkit r35177. Any confirmations?
Comment 2 Alexey Proskuryakov 2008-07-16 03:15:34 PDT
I cannot reproduce this in shipping Safari 3.1.1 either. Actually, I believe that this is handled by CFNetwork, not WebKit.