Bug 112444 - REGRESSION(r145802): This broke Chrome. (Requested by marja____ on #webkit).
Summary: REGRESSION(r145802): This broke Chrome. (Requested by marja____ on #webkit).
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Unspecified Unspecified
: P2 Normal
Assignee: WebKit Review Bot
URL:
Keywords:
Depends on:
Blocks: 111724
  Show dependency treegraph
 
Reported: 2013-03-15 07:09 PDT by WebKit Review Bot
Modified: 2013-03-15 07:16 PDT (History)
1 user (show)

See Also:


Attachments
ROLLOUT of r145802 (164.40 KB, patch)
2013-03-15 07:10 PDT, WebKit Review Bot
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description WebKit Review Bot 2013-03-15 07:09:53 PDT
http://trac.webkit.org/changeset/145802 broke the build:
This broke Chrome. (Requested by marja____ on #webkit).

This is an automatic bug report generated by the sheriff-bot. If this bug
report was created because of a flaky test, please file a bug for the flaky
test (if we don't already have one on file) and dup this bug against that bug
so that we can track how often these flaky tests case pain.

"Only you can prevent forest fires." -- Smokey the Bear
Comment 1 WebKit Review Bot 2013-03-15 07:10:29 PDT
Created attachment 193302 [details]
ROLLOUT of r145802

Any committer can land this patch automatically by marking it commit-queue+.  The commit-queue will build and test the patch before landing to ensure that the rollout will be successful.  This process takes approximately 15 minutes.

If you would like to land the rollout faster, you can use the following command:

  webkit-patch land-attachment ATTACHMENT_ID

where ATTACHMENT_ID is the ID of this attachment.
Comment 2 jochen 2013-03-15 07:13:42 PDT
For reference, here's a backtrace:

Thread 0 *CRASHED* ( EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE @ 0x00000000 )

0x01ad64ff	 [Google Chrome Framework]
0x0125f9b0	 [Google Chrome Framework]	 - WebBindings.cpp:262]	WebKit::WebBindings::getArrayBuffer
0x023d2a37	 [Google Chrome Framework]	 - npapi_glue.cc:146]	webkit::ppapi::NPObjectToPPVar
0x023d29df	 [Google Chrome Framework]	 - npapi_glue.cc:108]	webkit::ppapi::NPVariantToPPVar
0x023ec50f	 [Google Chrome Framework]	 - ppb_var_deprecated_impl.cc:208]	webkit::ppapi::::GetProperty
0x02e3453c	 [Google Chrome Framework]	 - ppb_var_deprecated_proxy.cc:433]	ppapi::proxy::PPB_Var_Deprecated_Proxy::OnMsgGetProperty
Comment 3 WebKit Review Bot 2013-03-15 07:16:31 PDT
Comment on attachment 193302 [details]
ROLLOUT of r145802

Clearing flags on attachment: 193302

Committed r145905: <http://trac.webkit.org/changeset/145905>
Comment 4 WebKit Review Bot 2013-03-15 07:16:34 PDT
All reviewed patches have been landed.  Closing bug.