Bug 111856 - Unable to upload photos to renren.com
Summary: Unable to upload photos to renren.com
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 528+ (Nightly build)
Hardware: Macintosh OS X 10.8
: P2 Normal
Assignee: Nobody
URL: http://www.renren.com
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-08 07:12 PST by Mr.Sky
Modified: 2013-03-28 22:57 PDT (History)
3 users (show)

See Also:


Attachments
this is the correct layout (625.53 KB, image/png)
2013-03-26 02:15 PDT, johnthinrony
no flags Details
this is the incorrect layout with the latest build (688.51 KB, image/png)
2013-03-26 02:19 PDT, johnthinrony
no flags Details
the layout for renren.com still incorrect (588.12 KB, image/png)
2013-03-27 23:46 PDT, johnthinrony
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mr.Sky 2013-03-08 07:12:07 PST
On a Chinese SNS above, some functions such as uploading photos can't work properly.
In the normal situation, a new window will pop-up if you click the icon. But after an update of webkit, nothing will happen after clicking that icon.
I really like surfing internet with webkit, so I do hope that you can solve this problem.
Thank you ~
Comment 1 Alexey Proskuryakov 2013-03-08 10:03:12 PST
Could you please provide more detailed steps to reproduce, and ideally attach a video with screen recording? I do not know what to do to try photo uploading on this site.
Comment 2 johnthinrony 2013-03-26 02:04:14 PDT
Me either, so I have to keep running older version...
Comment 3 johnthinrony 2013-03-26 02:13:58 PDT
Me either, so I have to keep running older version...
Comment 4 johnthinrony 2013-03-26 02:15:56 PDT
Created attachment 195036 [details]
this is the correct layout

It seems that it's not a CSS error.
Comment 5 johnthinrony 2013-03-26 02:19:30 PDT
Created attachment 195037 [details]
this is the incorrect layout with the latest build

actually, this bug appears several days ago, but it hasn't been fixed yet.
Comment 6 Alexey Proskuryakov 2013-03-26 08:35:14 PDT
See also: bug 113142. I'm not sure if that's the same issue, or a different one.
Comment 7 zalan 2013-03-26 08:46:53 PDT
Looks like the same layout issue as https://bugs.webkit.org/show_bug.cgi?id=113142, but not sure about the original problem. Could you change the cookie settings to not to block any cookies and try the photo upload again? I've came across issues like this due to some recent cross domain (local storage) changes.
Comment 8 Mr.Sky 2013-03-26 09:06:11 PDT
well, it had been fixed~!
Comment 9 Alexey Proskuryakov 2013-03-26 11:04:46 PDT
Just to double-check, are you saying that the original issue reported here no longer happens in current nightlies? So, can this bug be closed?
Comment 10 johnthinrony 2013-03-27 23:41:22 PDT
I'm not the first person who report this bug.

But the layout bug still haven't been fixed...I'm using the nightly build. later I'll upload an image..

(In reply to comment #9)
> Just to double-check, are you saying that the original issue reported here no longer happens in current nightlies? So, can this bug be closed?
Comment 11 johnthinrony 2013-03-27 23:46:15 PDT
Created attachment 195491 [details]
the layout for renren.com still incorrect

This bug appeared since build 528? I'm not sure. but build 449 works perfectly.
Comment 12 zalan 2013-03-28 02:18:12 PDT
(In reply to comment #10)
> I'm not the first person who report this bug.
> 
> But the layout bug still haven't been fixed...I'm using the nightly build. later I'll upload an image..
> 
> (In reply to comment #9)
> > Just to double-check, are you saying that the original issue reported here no longer happens in current nightlies? So, can this bug be closed?

Could you check again with the latest nightly?
r147073.dmg">http://builds.nightly.webkit.org/files/trunk/mac/WebKit-SVN-r147073.dmg

AFAICT, the sidebar is definitely fixed by bug 113142, but not sure about the comment box.
Comment 13 johnthinrony 2013-03-28 06:43:30 PDT
Yes! solved! It's really weird that when I update Webkit via "check for webkit updates" the problem still exists... now it's solved, thank you for your work!

(In reply to comment #12)
> (In reply to comment #10)
> > I'm not the first person who report this bug.
> > 
> > But the layout bug still haven't been fixed...I'm using the nightly build. later I'll upload an image..
> > 
> > (In reply to comment #9)
> > > Just to double-check, are you saying that the original issue reported here no longer happens in current nightlies? So, can this bug be closed?
> 
> Could you check again with the latest nightly?
> r147073.dmg">http://builds.nightly.webkit.org/files/trunk/mac/WebKit-SVN-r147073.dmg
> 
> AFAICT, the sidebar is definitely fixed by bug 113142, but not sure about the comment box.
Comment 14 zalan 2013-03-28 08:01:09 PDT
> Yes! solved! It's really weird that when I update Webkit via "check for webkit updates" the problem still exists... now it's solved, thank you for your work!
waiting for Mr.Sky to confirm that the original bug, unable to upload photos, is gone.