Bug 109688 - MediaStream API: Use the source id when creating new tracks
Summary: MediaStream API: Use the source id when creating new tracks
Status: RESOLVED FIXED
Alias: None
Product: WebKit
Classification: Unclassified
Component: WebKit API (show other bugs)
Version: 528+ (Nightly build)
Hardware: All All
: P2 Normal
Assignee: Tommy Widenflycht
URL:
Keywords:
Depends on:
Blocks: 56459
  Show dependency treegraph
 
Reported: 2013-02-13 06:16 PST by Tommy Widenflycht
Modified: 2013-02-13 12:34 PST (History)
10 users (show)

See Also:


Attachments
Patch (9.23 KB, patch)
2013-02-13 06:21 PST, Tommy Widenflycht
no flags Details | Formatted Diff | Diff
Patch (15.99 KB, patch)
2013-02-13 08:53 PST, Tommy Widenflycht
no flags Details | Formatted Diff | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tommy Widenflycht 2013-02-13 06:16:44 PST
MediaStream API: Use the source id when creating new tracks
Comment 1 Tommy Widenflycht 2013-02-13 06:21:19 PST
Created attachment 188072 [details]
Patch
Comment 2 WebKit Review Bot 2013-02-13 06:25:04 PST
Please wait for approval from abarth@webkit.org, dglazkov@chromium.org, fishd@chromium.org, jamesr@chromium.org or tkent@chromium.org before submitting, as this patch contains changes to the Chromium public API. See also https://trac.webkit.org/wiki/ChromiumWebKitAPI.
Comment 3 WebKit Review Bot 2013-02-13 07:14:22 PST
Comment on attachment 188072 [details]
Patch

Attachment 188072 [details] did not pass chromium-ews (chromium-xvfb):
Output: http://queues.webkit.org/results/16454861

New failing tests:
fast/mediastream/MediaStreamTrackList.html
Comment 4 Tommy Widenflycht 2013-02-13 08:53:35 PST
Created attachment 188089 [details]
Patch
Comment 5 Tommy Widenflycht 2013-02-13 08:54:52 PST
Added the correct new API to the patch as well as the work-around so that the tests work as intended again.
Comment 6 Adam Barth 2013-02-13 11:31:04 PST
Comment on attachment 188089 [details]
Patch

ok
Comment 7 WebKit Review Bot 2013-02-13 12:34:17 PST
Comment on attachment 188089 [details]
Patch

Clearing flags on attachment: 188089

Committed r142773: <http://trac.webkit.org/changeset/142773>
Comment 8 WebKit Review Bot 2013-02-13 12:34:21 PST
All reviewed patches have been landed.  Closing bug.