Bug 10964 - inclusion of svg into svg leave a ghost invisible rectangle
Summary: inclusion of svg into svg leave a ghost invisible rectangle
Status: RESOLVED DUPLICATE of bug 11984
Alias: None
Product: WebKit
Classification: Unclassified
Component: SVG (show other bugs)
Version: 420+
Hardware: Macintosh Intel OS X 10.4
: P2 Normal
Assignee: Nobody
URL: http://www.dernierage.com/ghost.svg
Keywords: NeedsReduction
Depends on:
Blocks:
 
Reported: 2006-09-20 23:48 PDT by Matthieu Chaton
Modified: 2007-01-08 16:40 PST (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthieu Chaton 2006-09-20 23:48:48 PDT
When including a svg into another svg at a given position and size, the svg is well included, but there is an invisible rectangle that is created, at postion 0,0 with the same dimensions that the svg included. 

The problem is that the rectangle is on the top of the other elements, and prevents me for tracking events in this area
Comment 1 Eric Seidel (no email) 2006-09-22 02:33:44 PDT
Could you please attach a test case, or link to an SVG demonstrating the problem?  Thanks.
Comment 2 Eric Seidel (no email) 2006-09-24 05:12:14 PDT
I'm very confused.  We'll need to reduce this to something simpler to understand what you're trying to demonstrate here.
Comment 3 Eric Seidel (no email) 2006-12-26 00:21:00 PST
Your "ghost" svg seems to be working.  But maybe I'm missing something?
Comment 4 Eric Seidel (no email) 2007-01-08 16:40:30 PST
Fixed by bug 11984.

*** This bug has been marked as a duplicate of 11984 ***