Bug 10941 - 3 crashes within a short time, doesn't seem specific to a page
Summary: 3 crashes within a short time, doesn't seem specific to a page
Status: RESOLVED WORKSFORME
Alias: None
Product: WebKit
Classification: Unclassified
Component: New Bugs (show other bugs)
Version: 420+
Hardware: Macintosh PowerPC OS X 10.4
: P1 Normal
Assignee: Nobody
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-19 18:19 PDT by Kevin M. Dean
Modified: 2007-02-07 04:57 PST (History)
2 users (show)

See Also:


Attachments
attached 3 crashlogs (89.43 KB, text/plain)
2006-09-19 18:20 PDT, Kevin M. Dean
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin M. Dean 2006-09-19 18:19:46 PDT
I just had 3 crashes within a short time after updating to r16456, doesn't seem specific to a page.
Comment 1 Kevin M. Dean 2006-09-19 18:20:51 PDT
Created attachment 10657 [details]
attached 3 crashlogs
Comment 2 Brady Eidson 2006-09-19 19:31:28 PDT
Can you give any better idea of what you were doing?  Was there anything in common with whatever pages caused these crashes?  Also, can you estimated (or say exactly) what version of WebKit you were using before you upgraded to 16456?
Comment 3 Kevin M. Dean 2006-09-19 19:42:30 PDT
I believe I was using r16442 or r16447. I'm currently running r16447 now to see if I have issues.

The last crash in my logs was simply after launching web kit and looking at the webkit bug reports to see if there was anyone else with issues and then it crashed.

The other 2 were also within a short period after launching and reading a few sites of content, such as maccentral.com, macupdate.com, versiontracker.com.
Comment 4 Kevin M. Dean 2006-09-19 19:59:23 PDT
r16456 - I can't open my bookmark to this bugreport with it crashing.
r16452 – I can open my bookmark but not the bookmarks window
r16440 --> r16456 - I can't open my bookmarks window by clicking the toolbar icon without it crashing.

r16421 - I can open my bookmarks window again without crashing.

Oddly after running r16421, I can open the bookmarks window without crashing all the way back up to r16456, but opening my bookmark for this bug still crashes
Comment 5 Kevin M. Dean 2006-09-19 20:01:20 PDT
r16458 - I can open the bookmark again without crashing. I'll try this version to see if any other issues continue.
Comment 6 Kevin M. Dean 2006-09-19 22:14:45 PDT
After using r16458 for a while, it seems that it has resolved the crashes that I was getting.
Comment 7 Brady Eidson 2006-09-19 22:43:37 PDT
If it no longer repros in 16258 thats great - but I if it *does* repro in 16256, that's peculiar - as can't wrap my head around why 16257 or 16258 could've fixed this crash...
Comment 8 David Kilzer (:ddkilzer) 2006-09-20 04:49:27 PDT
Stack trace #3 in Bug 10941 (Attachment 10657 [details]) is very similar to the stack trace in Bug 10942 (Attachment 10659 [details]).
Comment 9 Mark Rowe (bdash) 2007-02-06 21:53:53 PST
This bug has zero steps to reproduce, and hasn't been touched in nearly 6 months.  It seems unlikely that it's still relevant.
Comment 10 Maciej Stachowiak 2007-02-07 04:57:50 PST
Closing, since there are no steps to reproduce and the stack traces seem unrelated to each other.